maven-wagon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Darren Hartford" <dhartf...@ghsinc.com>
Subject RE: Wagon-webdav distribution - where to put username/password
Date Wed, 07 Jun 2006 18:27:01 GMT
Reposting on Wagon user list, although it's not that active...

Attempting to use an Apache 2.2 webdav server to distribute artifacts
(see below details).

*Require username/password authentication.
*Will be testing https right after, so please let me know of any issues
related to that as well :-)

Thanks,
-D

> -----Original Message-----
> From: Darren Hartford 
> Sent: Wednesday, June 07, 2006 2:11 PM
> To: users@maven.apache.org
> Subject: Wagon-webdav distribution - where to put username/password
> 
> Hey all,
> I'm trying to distribute artifacts to a webdav server, but I 
> do not seem to know where to put the username/password.  When 
> the webdav server (apache 2.2) is un-secured, it works fine.
> 
> Configured Maven as follows:
> 
> Pom.xml
> =========================
>     <distributionManagement>
>         <repository>
>             <id>my-secure-repo</id>
>             <url>dav:http://reposerver/myrepo</url>
> ...
> ==========================
> 
> Then tried settings.xml
> ======================
> <servers>
>     <server>
>       <id>my-secure-repo</id>
>       <username>userthingy</username>
> 	<password>passwordthingy</password>
> ......
> ======================
> 
> Any ideas please?  If this is documented somewhere, please 
> point me to the location. Been 'working' with this for most 
> of this week, a quick answer would definitely help!
> 
> -D

---------------------------------------------------------------------
To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
For additional commands, e-mail: wagon-users-help@maven.apache.org


Mime
View raw message