maven-wagon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Yann Le Du (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (WAGON-30) wagon-file failed when used by maven-site-plugin
Date Mon, 23 Jan 2006 10:04:06 GMT
    [ http://jira.codehaus.org/browse/WAGON-30?page=comments#action_56640 ] 

Yann Le Du commented on WAGON-30:
---------------------------------

Even with the patch, wagon-file fails for directories that don't already exist. If you can,
first create required directories then run deploy again.

> wagon-file failed when used by maven-site-plugin
> ------------------------------------------------
>
>          Key: WAGON-30
>          URL: http://jira.codehaus.org/browse/WAGON-30
>      Project: wagon
>         Type: Bug

>     Versions: 1.0-alpha-6
>     Reporter: Gilles Scokart
>  Attachments: wagon-file-1.0-alpha-7-SNAPSHOT.jar, wagon-file.patch, wagon-provider-test.patch
>
>
> When maven-site-plugin try a deploy on a file URL, an error is triggered.  This is because
maven-site-plugin call "wagon.putDirectory( inputDirectory, "." );" which fails.
> See http://www.nabble.com/With-maven-2.0.2-site%3Adeploy-doesn%27t-work-t934716.html
> In attachment, you can find a patch adding a test case, and the patch fixing the bug.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: wagon-dev-unsubscribe@maven.apache.org
For additional commands, e-mail: wagon-dev-help@maven.apache.org


Mime
View raw message