maven-wagon-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Samuel Le Berrigaud (JIRA)" <j...@codehaus.org>
Subject [jira] Commented: (WAGON-30) wagon-file failed when used by maven-site-plugin
Date Sun, 22 Jan 2006 11:15:06 GMT
    [ http://jira.codehaus.org/browse/WAGON-30?page=comments#action_56589 ] 

Samuel Le Berrigaud commented on WAGON-30:
------------------------------------------

Sorry hit "Enter" involuntarily...

Does maven uses first the libraries that are in local repository in precendence to those in
the MAVEN_HOME/lib... I think this could explain why it doesn't work for me... 

> wagon-file failed when used by maven-site-plugin
> ------------------------------------------------
>
>          Key: WAGON-30
>          URL: http://jira.codehaus.org/browse/WAGON-30
>      Project: wagon
>         Type: Bug

>     Versions: 1.0-alpha-6
>     Reporter: Gilles Scokart
>  Attachments: wagon-file-1.0-alpha-7-SNAPSHOT.jar, wagon-file.patch, wagon-provider-test.patch
>
>
> When maven-site-plugin try a deploy on a file URL, an error is triggered.  This is because
maven-site-plugin call "wagon.putDirectory( inputDirectory, "." );" which fails.
> See http://www.nabble.com/With-maven-2.0.2-site%3Adeploy-doesn%27t-work-t934716.html
> In attachment, you can find a patch adding a test case, and the patch fixing the bug.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://jira.codehaus.org/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


---------------------------------------------------------------------
To unsubscribe, e-mail: wagon-dev-unsubscribe@maven.apache.org
For additional commands, e-mail: wagon-dev-help@maven.apache.org


Mime
View raw message