maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Barboni" <sk...@apache.org>
Subject RE: Netbeans Maven module with Java 9 plain module dependency does not work
Date Fri, 12 Jul 2019 12:27:19 GMT
Sorry wrong ml.

Regards
Eric

-----Message d'origine-----
De : Eric Barboni <skygo@apache.org> 
Envoyé : vendredi 12 juillet 2019 14:23
À : 'Maven Users List' <users@maven.apache.org>
Objet : RE: Netbeans Maven module with Java 9 plain module dependency does not work

Hi,

Please use the 4.2 version

<groupId>org.apache.netbeans.utilities</groupId>

<artifactId>nbm-maven-plugin</artifactId>

<version>4.2</version>

 

Jar generated by jdk>8 cannot be parsed by older version on the plugin.

 

Regards

Eric

 

De : Geertjan Wielenga <geertjan@apache.org> Envoyé : vendredi 12 juillet 2019 11:25
À : Klaus Martinschitz <klausmartinschitz@gmail.com> Cc : NetBeans Mailing List <users@netbeans.apache.org>
Objet : Re: Netbeans Maven module with Java 9 plain module dependency does not work

 

Which version of NetBeans? Which JDK? Which operating system?

 

This seems to be related: https://github.com/mojohaus/nbm-maven-plugin/issues/30

 

Gj

 

On Fri, Jul 12, 2019 at 3:06 AM Klaus Martinschitz <klausmartinschitz@gmail.com <mailto:klausmartinschitz@gmail.com>
> wrote:

Hello,

 

I created a very simple Netbeans Module app, containing

·         The aggregator Module  (it’s called parent)

·         The app module

·         The branding module

·         An additional Netbeans module, let’s call it X.

 

Everything works fine on compile.

 

Now, I have got a plain Java module with source level 9 (Jigsaw) containing a module-info.class
file. Compiling works perfect.

 

However, If I add the plain Java module with  source level 9 to my X module, I get a compilation
failure. The error is…

 

Failed to execute goal org.codehaus.mojo:nbm-maven-plugin:4.1:manifest (default-manifest)
on project Module: Execution default-manifest of goal org.codehaus.mojo:nbm-maven-plugin:4.1:manifest
failed.: IllegalArgumentException -> [Help 1]

 

To see the full stack trace of the errors, re-run Maven with the -e switch. Re-run Maven using
the -X switch to enable full debug logging.

 

For more information about the errors and possible solutions, please read the following articles:
[Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException

 

After correcting the problems, you can resume the build with the command   mvn <goals>
-rf :Module

 

Is it possible that Java 9 modules cannot be added as dependency to a Netbeans Maven module?

 

Thanks.

 

Regards,

Klaus

 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message