maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Fox <jos...@freightos.com>
Subject Re: Double copy of XML in POMs
Date Mon, 06 Aug 2018 07:56:00 GMT
Thank you! Good to know that is is being handled. (It is not a blocker
since we deleted the repository and forced a new download.)

On Fri, Aug 3, 2018 at 11:07 AM Robert Scholte <rfscholte@apache.org> wrote:

> Yes, this is a known issue, see  MNG-6281[1] Up until Maven 3.3.9 this was
> never an issue, until we fixed  MNG-6020[2]. Before that Maven stopped
> reading after the closing root-tag.
> It is very hard to reproduce. One of the possibilities I have in mind is
> that the same pom is required twice (either by 2 Maven executions or as
> part of the reactor) and that the files are appended.
> I still think  MNG-6020 is a good fix: the file must contain valid XML. So
> I'd love to see an explanation for this weird behavior and fix it.
>
> thanks,
> Robert
>
> [1] https://issues.apache.org/jira/browse/MNG-6281
> [2] https://issues.apache.org/jira/browse/MNG-6020
>
> On Thu, 02 Aug 2018 12:48:52 +0200, Joshua Fox <joshua@freightos.com>
> wrote:
>
> I got a lot of these error messages using Maven 3.5 on Windows 10.
>
> *The POM for… jar…  is invalid, transitive dependencies (if any) will not
> be available, enable debug logging for more details*
>
>
> It turns out that the POM files consisted  of a *double copy *of the XML!
> See the attached example.
>
> I removed ~/.m2/ and rebuilt, and the POMs were  OK.
>
> Is this a known issue? It is very strange to see XML appearing twice.
>
>
>
>
>

-- 


*JOSHUA FOX*
Director, Software Architecture | Freightos



*T (Israel): *+972-545691165 | *T (US)*:  +1-3123400953
Smooth shipping.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message