maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mehul Sanghvi <mehul.sang...@gmail.com>
Subject Re: Maven return code 502, ReasonPhrase:notresolvable
Date Sun, 13 Aug 2017 16:29:48 GMT
I upgraded my Nexus OSS server to version 2.14.5-02, and I still see the
same issue.  All new builds that I have
get affected by this, unless I manually copy the artefacts from an existing
local maven repository.

I have rebuilt the metadata, re-built the indexes, etc. as well.  Still the
same result.

Anyone have any thoughts/suggestions/pointers ?

cheers,

     mehul


On Wed, Jul 26, 2017 at 9:21 AM, Mehul Sanghvi <mehul.sanghvi@gmail.com>
wrote:

> Maven version:  3.3.3
> Nexus version:   OSS 2.14.o-1
>
> Starting this past Monday, I have been seeing the following:
>
>
> build 25-Jul-2017 20:27:16 [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-antrun-plugin:1.3:run (default) on project
> xml2jsonMigration: Execution default of goal
> org.apache.maven.plugins:maven-antrun-plugin:1.3:run failed: Plugin
> org.apache.maven.plugins:maven-antrun-plugin:1.3 or one of its
> dependencies
> could not be resolved: The following artifacts could not be resolved:
> org.apache.maven:maven-plugin-api:jar:2.0.4,
> org.apache.maven:maven-project:jar:2.0.4,
> org.apache.maven:maven-settings:jar:2.0.4,
> org.apache.maven:maven-profile:jar:2.0.4,
> org.apache.maven:maven-model:jar:2.0.4,
> org.apache.maven:maven-artifact-manager:jar:2.0.4,
> org.apache.maven:maven-repository-metadata:jar:2.0.4,
> org.apache.maven:maven-artifact:jar:2.0.4,
> org.codehaus.plexus:plexus-utils:jar:1.5.6: Could not transfer artifact
> org.apache.maven:maven-plugin-api:jar:2.0.4 from/to releases
> (http://nexus.myorg.com:8081/nexus/content/groups/releases/): Failed to
> transfer file:
> http://nexus.myorg.com:8081/nexus/content/groups/releases/
> org/apache/maven/maven-plugin-api/2.0.4/maven-plugin-api-2.0.4.jar.
> Return code is: 502 ,
> ReasonPhrase:notresolvable.
>
>
> At first it was for an artefact that was located in an internal corporate
> Artifactory repository, which I was able to get past by modifying the proxy
> settings in the settings.xml file.   It used to be:
>
>             <nonProxyHosts>*.myorg.com</nonProxyHosts>
>
> and I changed it to
>
>             <nonProxyHosts>*.myorg.com|*.mycorp.com</nonProxyHosts>
>
>
>
> The error above that I am getting though, is for something that was
> working.  And the artefacts are accessible via the web browser.  From a
> network standpoint, the Nexus server is one hop away (based on traceroute
> information).
>
> This used to work.   There have been no network changes,  not VM changes,
>  no updates to Maven.   We did change the version number of our product by
> removing the -SNAPSHOT, but that should not cause this error that we are
> seeing.
>
> I have tried using the -U command line option, as well as just pointing
> maven.repo.local to a new location and avoiding any cacheing issues.
>
>
> Any pointers/suggestions/thoughts ?
>
> --
> Mehul N. Sanghvi
> email: mehul.sanghvi@gmail.com
>



-- 
Mehul N. Sanghvi
email: mehul.sanghvi@gmail.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message