maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Gudian <andreas.gud...@gmail.com>
Subject Re: Anyone using annotationProcessorPaths in maven-compiler-plugin
Date Sat, 26 Mar 2016 11:28:08 GMT
Right, in 3.5.1 I fixed an oversight that caused the modules direct
dependencies to also show up in -processorpath.

So anyway, in 3.5.1, it should work just as expected. Are you maybe using a
different plexus-compiler implementation by configuring an
addidtional plugin-dependency?

Here's another example config that does work:
http://mapstruct.org/documentation/1.1/reference/html/index.html#setup

Andreas

Am Samstag, 26. März 2016 schrieb Mark Derricutt :

> This was using 1.8 and the 3.5.1 of the compiler plugin ( which seems to
> have quite major differences in behaviour to 3.5 ), which I think it uses
> the tools api and not calling javac ( I do note theres an option to force
> using javac tho ) so might give that a shot.
>
> --
> "Great artists are extremely selfish and arrogant things" — Steven Wilson,
> Porcupine Tree
>
> On Fri, Mar 25, 2016 at 8:26 PM, Thomas Broyer <t.broyer@gmail.com
> <javascript:;>> wrote:
>
> > Have you set source and target to at least 1.6 or 6?
> > You should see the -processorpath argument being passed to JavaC when
> > running with -X.
> >
> > Le jeu. 24 mars 2016 00:37, Mark Derricutt <mark@talios.com
> <javascript:;>> a écrit :
> >
> > > Hey all,
> > >
> > > Has anyone successfully used the new <annotationProcessorPaths> setting
> > > in the maven-compiler-plugin at all?
> > >
> > > I'm adding:
> > >
> > > <annotationProcessorPaths>
> > >   <path>
> > >     <groupId>com.google.dagger</groupId>
> > >     <artifactId>dagger-compiler</artifactId>
> > >     <version>2.1</version>
> > >   </path></annotationProcessorPaths>
> > >
> > > to my compiler plugins configuration but it doesn't seem to work, when
> > > running maven with -X I see the configuration is picked up, but it
> > doesn't
> > > seem to get passed to the compiler at all?
> > >
> > > [DEBUG] Goal:
> > org.apache.maven.plugins:maven-compiler-plugin:3.5.1:compile
> > (default-compile)
> > > [DEBUG] Style:         Regular
> > > [DEBUG] Configuration: <?xml version="1.0"
> > encoding="UTF-8"?><configuration>
> > >   <annotationProcessorPaths>
> > >     <path>
> > >       <groupId>com.google.dagger</groupId>
> > >       <artifactId>dagger-compiler</artifactId>
> > >       <version>2.1</version>
> > >     </path>
> > >   </annotationProcessorPaths>
> > >   <basedir default-value="${basedir}"/>
> > >   <buildDirectory default-value="${project.build.directory}"/>
> > >   <classpathElements
> > default-value="${project.compileClasspathElements}"/>
> > >   <compileSourceRoots default-value="${project.compileSourceRoots}"/>
> > >   <compilerId
> > default-value="javac">${maven.compiler.compilerId}</compilerId>
> > >   <compilerReuseStrategy
> >
> default-value="${reuseCreated}">${maven.compiler.compilerReuseStrategy}</compilerReuseStrategy>
> > >   <compilerVersion>${maven.compiler.compilerVersion}</compilerVersion>
> > >   <debug default-value="true">${maven.compiler.debug}</debug>
> > >   <debuglevel>${maven.compiler.debuglevel}</debuglevel>
> > >   <encoding
> > default-value="${project.build.sourceEncoding}">${encoding}</encoding>
> > >   <executable>${maven.compiler.executable}</executable>
> > >   <failOnError
> > default-value="true">${maven.compiler.failOnError}</failOnError>
> > >   <forceJavacCompilerUse
> >
> default-value="false">${maven.compiler.forceJavacCompilerUse}</forceJavacCompilerUse>
> > >   <fork default-value="false">${maven.compiler.fork}</fork>
> > >   <generatedSourcesDirectory
> >
> default-value="${project.build.directory}/generated-sources/annotations"/>
> > >   <maxmem>${maven.compiler.maxmem}</maxmem>
> > >   <meminitial>${maven.compiler.meminitial}</meminitial>
> > >   <mojoExecution default-value="${mojoExecution}"/>
> > >   <optimize default-value="false">${maven.compiler.optimize}</optimize>
> > >   <outputDirectory default-value="${project.build.outputDirectory}"/>
> > >   <project default-value="${project}"/>
> > >   <projectArtifact default-value="${project.artifact}"/>
> > >   <session default-value="${session}"/>
> > >   <showDeprecation
> > default-value="false">${maven.compiler.showDeprecation}</showDeprecation>
> > >   <showWarnings
> > default-value="false">${maven.compiler.showWarnings}</showWarnings>
> > >   <skipMain>${maven.main.skip}</skipMain>
> > >   <skipMultiThreadWarning
> >
> default-value="false">${maven.compiler.skipMultiThreadWarning}</skipMultiThreadWarning>
> > >   <source default-value="1.5">${maven.compiler.source}</source>
> > >   <staleMillis default-value="0">${lastModGranularityMs}</staleMillis>
> > >   <target default-value="1.5">${maven.compiler.target}</target>
> > >   <useIncrementalCompilation
> >
> default-value="true">${maven.compiler.useIncrementalCompilation}</useIncrementalCompilation>
> > >   <verbose
> > default-value="false">${maven.compiler.verbose}</verbose></configuration>
> > >
> > > When running the compiler with <verbose>true</verbose> I don't
see the
> > > dagger-compiler artefact anywhere on the paths mentioned ( to be
> expected
> > > since it should be on the annotation path not class-path, but we don't
> > > print out the annotation path ).
> > >
> > > Am I missing something simple? Including dagger-compiler as a normal
> > > dependency works fine, but then bleeds into the class path.
> > >
> > > Mark
> > >
> > > --
> > > Mark Derricutt
> > > http://www.theoryinpractice.net
> > > http://www.chaliceofblood.net
> > > http://plus.google.com/+MarkDerricutt
> > > http://twitter.com/talios
> > > http://facebook.com/mderricutt
> > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message