maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric B <ebenza...@gmail.com>
Subject Re: variable doesn't work for version
Date Mon, 07 Mar 2016 19:18:31 GMT
I personally have a pet-peeve of using system variables to define version
numbers; I find it is counter productive to the building of maven
artifacts.  There is no traceability to determine  the actual version of an
artifact once it has been built.  At least having a fixed version number in
the <version> element shows up in the META-INF/maven/../pom.* files.

Is using a variable for the version even a good idea?

Thanks,

Eric


On Mon, Mar 7, 2016 at 4:04 AM, Stephen Connolly <
stephen.alan.connolly@gmail.com> wrote:

> only specific properties are permitted for expansion in XPath paths that
> match the following regex /project/(parent/)?(groupId|artifactId|version)
>
> On 2 March 2016 at 05:39, Raghu <raghunath_ku@yahoo.com.invalid> wrote:
>
> > I have a POM with parent node as below: <parent>
> > <groupId>com.test</groupId> <artifactId>pom.parent</artifactId>
> > <version>${test.version}</version>
> > <relativePath>../scripts/pom.xml</relativePath> </parent>
> > This used to work till maven 3.3.3 version - mvn clean install. However,
> > the version 3.3.9 throws error though. When I change the version to a
> value
> > instead of the variable, it works fine.
> > Won't maven support variable for version? Or is it a bug with 3.3.9?
> > Appreciate your response...
> > - regards,raghu
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message