maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Elliot Metsger <emets...@gmail.com>
Subject Site Plugin 3.5 URL behavior and multi-module builds
Date Thu, 10 Mar 2016 14:29:09 GMT
Hi,

I'm using the Maven site plugin with a multi-module build.  The generated
site is going to be deployed to GitHub, so I'm only using the Maven site
plugin to generate and stage content locally, not deploy.

I have a placeholder distributionManagement/site element in my POM so that
site:stage can generate links between the modules of my site.  However, my
child modules are getting inexplicable values for their site url:

Parent module distributionManagement/site (${project.url} =
http://dataconservancy.github.io/package-ingest):

  <distributionManagement>
    <site>
      <id>github</id>
      <name>GitHub Pages Website</name>
      <url>${project.url}</url>
    </site>
  </distributionManagement>

Parent module, help:effective-pom:
    <distributionManagement>
      <site>
        <id>github</id>
        <name>GitHub Pages Website</name>
        <url>http://dataconservancy.github.io/package-ingest</url>
      </site>
    </distributionManagement>

So far, so good.  However, the child module's
distributionManagement/site/url is not what I expected.  Notice that the
child module name 'package-ingest-api' is repeated twice in the url:

Child module, help:effective-pom (project url =
http://dataconservancy.github.io/package-ingest/package-ingest-api/)
  <distributionManagement>
    <site>
      <id>github</id>
      <name>GitHub Pages Website</name>
      <url>
http://dataconservancy.github.io/package-ingest/package-ingest-api/package-ingest-api
</url>
    </site>
  </distributionManagement>

Is this expected behavior?

Thanks,
Elliot

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message