maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Gudian <agud...@apache.org>
Subject [ANN] Apache Maven Compiler Plugin Version 3.5 Released
Date Wed, 20 Jan 2016 19:43:10 GMT
The Apache Maven team is pleased to announce the release of the Apache
Maven Compiler Plugin, version 3.5.

The Compiler Plugin is used to compile the sources of your project.

http://maven.apache.org/plugins/maven-compiler-plugin/

You should specify the version in your project's plugin configuration:

<plugin>
  <groupId>org.apache.maven.plugins</groupId>
  <artifactId>maven-compiler-plugin</artifactId>
  <version>3.5</version>
</plugin>

Attention: Starting with this version, the maven-compiler-plugin requires
Maven 3 and won't work with Maven 2 anymore.


Release Notes - Maven Compiler Plugin - Version 3.5

** New Feature
    * [MCOMPILER-203] - Allow compiler-plugin to specify annotation
processor dependencies

** Bug
    * [MCOMPILER-211] - Compiler plugin (3.x) fails in eclipse

** Improvement
    * [MCOMPILER-257] - Require Maven 3.0
    * [MCOMPILER-258] - Removing exclusions from maven-core
    * [MCOMPILER-259] - Upgrade maven-shared-utils to 3.0.0


Enjoy,

-The Apache Maven team

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message