maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Trasuk <tras...@stratuscom.com>
Subject Re: Installing on Solaris
Date Fri, 06 Nov 2015 17:50:07 GMT

Hi James:

Based on your class path, it looks like you installed the “Java Runtime Environment”.
 That’s just the Java virtual machine without the Java Compiler.  Maven is going to need
the Java Compiler, so you’ll need to get the Java SE version (Standard Edition, appears
to be at http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html).

Having said that, it looks odd that it’s having trouble finding ‘libjava.so’.  There
might be something funny about your JDK installation.  Maybe that gives you a place to start
looking…

Basically, before Maven has any chance at working, you need to make sure that you can run
‘javac -version’ and it comes back with 1.7 or higher.

Cheers,

Greg Trasuk
http://www.webagesolutions.com


> On Nov 6, 2015, at 12:36 PM, james pruett <gpscruise@gmail.com> wrote:
> 
> Hi,
> 
> I get this error. Any help appreciated.
> 
> 
> % mvn
> Error: could not find libjava.so
> Error: Could not find Java SE Runtime Environment.
> 
> % env | grep -i CLASSPATH
> CLASSPATH=/export/home/e0857723/aaa_bonita/jdk17/jdk1.7.0_79/jre/lib/sparcv9
> 
> 
> % ls -las $CLASSPATH/libjava.so
> 524 -rwxrwxrwx   1    267912 Apr 10  2015
> /export/home/e0857723/aaa_bonita/jdk17/jdk1.7.0_79/jre/lib/sparcv9/libjava.so


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message