maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason van Zyl <ja...@takari.io>
Subject Re: maven-plugin-testing-harness: NoClassDefFoundError: org/apache/maven/execution/MavenExecutionRequest
Date Fri, 13 Nov 2015 22:09:36 GMT
You must be running with a version of Maven where that class does not exist? That error means
you’re using a library where that class was present during building but not present at runtime.
You running something older than Maven 2.2.x?

> On Nov 13, 2015, at 4:59 PM, org.apache.maven.user@io7m.com wrote:
> 
> On 2015-11-13T21:07:23 +0000
> <org.apache.maven.user@io7m.com> wrote:
> 
>> On 2015-11-13T21:39:06 +0100
>> Karl Heinz Marbaise <khmarbaise@gmx.de> wrote:
>>> 
>>> Better use at least version 3.0 of this...
>> 
>> I'll try 3.0.
> 
> No luck, unfortunately. Same error.
> 
> M
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder, Takari and Apache Maven
http://twitter.com/jvanzyl
http://twitter.com/takari_io
---------------------------------------------------------

happiness is like a butterfly: the more you chase it, the more it will
elude you, but if you turn your attention to other things, it will come
and sit softly on your shoulder ...

-- Thoreau 













---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message