maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jarl <j...@ironcity.us>
Subject Re: Maven stops building class files after Enum file added to project.
Date Mon, 09 Nov 2015 20:00:48 GMT
Once a 'clean' is performed all subsequent builds leave classes 
directory empty.   I can copy a working project to a new directory but i 
can only get the first build to work.   Is there way to actually clean 
maven build artifacts other than mvn clean?

On 11/9/2015 8:30 PM, Karl Heinz Marbaise wrote:
> Hi,
>
> those lines:
>
> [INFO] Assembling webapp [myProject] in 
> [C:\myProject\target\myProject-2.1.0]
> [INFO] Processing war project
> [INFO] Copying webapp resources [C:\myProject\src\main\webapp]
> [INFO] Webapp assembled in [661 msecs]
> [INFO] Building war: C:\apache-tomcat-7.0.64\webapps\myProject-2.1.0.war
> [INFO]
>
> look strange cause building the war is a different folder than 
> building the rest of the project...
>
> Have you tested to do a mvn clean ...
>
> before doing mvn package ?
>
> Kind regards
> Karl Heinz Marbaise
>
> On 11/9/15 8:13 PM, Jarl wrote:
>> No error messages.
>>
>> [INFO] --- maven-compiler-plugin:3.3:compile (default-compile) @
>> myProject---
>> [INFO] Changes detected - recompiling the module!
>> [INFO] Compiling 295 source files to C:\myProject\target\classes
>> [INFO]
>> [INFO] --- maven-war-plugin:2.3:war (default-war) @ myProject---
>> [INFO] Packaging webapp
>> [INFO] Assembling webapp [myProject] in
>> [C:\myProject\target\myProject-2.1.0]
>> [INFO] Processing war project
>> [INFO] Copying webapp resources [C:\myProject\src\main\webapp]
>> [INFO] Webapp assembled in [661 msecs]
>> [INFO] Building war: C:\apache-tomcat-7.0.64\webapps\myProject-2.1.0.war
>> [INFO]
>> [INFO] --- maven-install-plugin:2.4:install (default-install) @
>> myProject---
>> [INFO] Installing C:\apache-tomcat-7.0.64\webapps\myProject-2.1.0.war to
>> C:\Users\admin\.m2\repository\com\nsb\myProject\myProject\2.1.0\myProject-2.1.0.war

>>
>>
>> [INFO] Installing C:\myProject\pom.xml to
>> C:\Users\admin\.m2\repository\com\nsb\myProject\myProject\2.1.0\myProject-2.1.0.pom

>>
>>
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] BUILD SUCCESS
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 8.935 s
>> [INFO] Finished at: 2015-11-09T19:47:32+01:00
>> [INFO] Final Memory: 23M/224M
>>
>>
>>
>> On 11/9/2015 8:04 PM, Karl Heinz Marbaise wrote:
>>>
>>> Error messages ?
>>> Log output ?
>>>
>>>
>>> Kind regards
>>> Karl Heinz Marbaise
>>> On 11/9/15 7:59 PM, Jarl wrote:
>>>> The build succeeds but the target/classes directory is empty of any
>>>> class files.
>>>>
>>>> -Jarl
>>>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org

-- 
-Jarl


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message