maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bernd Eckenfels <e...@zusammenkunft.net>
Subject Re: SNAPSHOT jar incorrectly downloaded
Date Mon, 09 Nov 2015 11:13:58 GMT
Hello,

check the /opt/jenkins/mvn-settings.xml files, if it specifies
anything for the repo or distributions or proxy or similiar.


Gruss
Bernd

Am Mon, 9
Nov 2015 12:07:35 +0100 schrieb ml@mherrn.de:

> Hmm, the metadata files seems correct. It references the file with the
> timestamp. Also on the workstation if works well.
> 
> A difference I see is that the build on the workstation downloads the
> maven-metadata.xml, but the jenkins build doesn't.
> 
> I assume this can be the problem. But why is this the case? And how
> can I fix it?
> 
> Unfortunately cleaning the local repository doesn't help
> .
> 
> > I observe this happening from time to time when both maven2 and
> > maven3 builds are using the same local repository. Maven2 seems to
> > modify metadata
> > files in a way that maven3 fails to work with.
> > Cleaning bogus artifacts from local repo makes the problem go away.
> >
> > 2015-11-09 12:31 GMT+02:00 <ml@mherrn.de>:
> >
> >> Hi,
> >>
> >> I am using jenkins as a build server that uses an apache archiva
> >> repository as default repository. That repository is specified by a
> >> custom
> >> settings.xml I provide to the build.
> >>
> >> Now when building such a maven project it tries to download the
> >> dependencies from apache archiva, but fails, because it references
> >> the wrong pom.
> >>
> >> Here is the output of the build:
> >>
> >> ----/----
> >> <===[JENKINS REMOTING CAPACITY]===>channel started
> >> Executing Maven:  -B -f /mnt/raid/jenkins/workspace/MvnTest/pom.xml
> >> -Dmaven.repo.local=/mnt/raid/jenkins/maven-repositories/1 -s
> >> /opt/jenkins/mvn-settings.xml clean package
> >> [INFO] Scanning for projects...
> >> [INFO]
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] Building MvnTest 1.0-SNAPSHOT
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> Downloading:
> >>
> >> http://192.168.30.10:5501/repository/BFR/myproject/Commons/1.0-SNAPSHOT/Commons-1.0-SNAPSHOT.pom
> >> [WARNING] The POM for myproject:Commons:jar:1.0-SNAPSHOT is
> >> missing, no dependency information available
> >> Downloading:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/Commons-1.0-SNAPSHOT.jar
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] BUILD FAILURE
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] Total time: 3.091s
> >> [INFO] Finished at: Mon Nov 09 11:21:57 CET 2015
> >> [INFO] Final Memory: 7M/20M
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [ERROR] Failed to execute goal on project MvnTest: Could not
> >> resolve dependencies for project
> >> myproject:MvnTest:jar:1.0-SNAPSHOT: Could not find artifact
> >> myproject:Commons:jar:1.0-SNAPSHOT in MYREPO
> >> (http://192.168.30.10:5501/repository/MYREPO) -> [Help 1] [ERROR]
> >> [ERROR] To see the full stack trace of the errors, re-run Maven
> >> with the -e switch.
> >> [ERROR] Re-run Maven using the -X switch to enable full debug
> >> logging. [ERROR]
> >> [ERROR] For more information about the errors and possible
> >> solutions, please read the following articles:
> >> [ERROR] [Help 1]
> >>
> >> http://cwiki.apache.org/confluence/display/MAVEN/DependencyResolutionException
> >> ----/----
> >>
> >> The interesting thing is that is tries to download
> >> Commons-1.0-SNAPSHOT.jar, which really does not exist. The files
> >> are named
> >> like Commons-1.0-20151109.083301-1.jar.
> >>
> >> When building this project on my workstation it works, but the
> >> output is also different:
> >>
> >> ----/----
> >> [INFO] Scanning for projects...
> >> [INFO]
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> [INFO] Building MvnTest 1.0-SNAPSHOT
> >> [INFO]
> >> ------------------------------------------------------------------------
> >> Downloading:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/maven-metadata.xml
> >> Downloading:
> >> http://central/myproject/Commons/1.0-SNAPSHOT/maven-metadata.xml
> >> Downloaded:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/maven-metadata.xml
> >> (357 B at 1.0 KB/sec)
> >> [WARNING] Could not transfer metadata
> >> myproject:Commons:1.0-SNAPSHOT/maven-metadata.xml from/to
> >> central-snap (http://central): central: unknown error
> >> Downloading:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/Commons-1.0-20151109.095759-4.pom
> >> Downloaded:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/Commons-1.0-20151109.095759-4.pom
> >> (2 KB at 19.0 KB/sec)
> >> Downloading:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/Commons-1.0-20151109.095759-4.jar
> >> Downloaded:
> >>
> >> http://192.168.30.10:5501/repository/MYREPO/myproject/Commons/1.0-SNAPSHOT/Commons-1.0-20151109.095759-4.jar
> >> (90 KB at 528.9 KB/sec)
> >> [...]
> >> ----/----
> >>
> >> What is going on here?
> >> Thanks in advance
> >>
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> >> For additional commands, e-mail: users-help@maven.apache.org
> >>
> >>
> >
> >
> > --
> > Regards,
> > Anton.
> >
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message