maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte" <rfscho...@apache.org>
Subject Re: deployAtEnd really works?
Date Thu, 14 May 2015 10:08:26 GMT
deployAtEnd works for most projects, not all. Hence, it is 'false' by  
default.

Improvements need to be made in Maven Core itself[1]
It seems like Jason wants to fix this for the next release.

[1] https://issues.apache.org/jira/browse/MNG-5666

Op Thu, 14 May 2015 10:21:19 +0200 schreef Karl Heinz Marbaise  
<khmarbaise@gmx.de>:

> Hi Dan,
>
> On 5/14/15 8:12 AM, Dan Tran wrote:
>> Hi Bernd ,
>>
>> I dont configure or execute any maven-deploy-plugin at my top level  
>> parent
>> pom.
>>
>> The only thing that I have which may not be very conventional:
>>
>> all of my modules are conditional activated by profile looking for  
>> existing
>> existing pom
>>
>>      <profile>
>>        <id>enable-compX</id>
>>        <activation>
>>          <file>
>>            <exists>components/compX/pom.xml</exists>
>>          </file>
>>        </activation>
>>        <modules>
>>          <module>components/compX</module>
>>        </modules>
>>      </profile>
>>
>>
>> I am using Maven 3.2.3
>
> What's the reason having a module activating via profile...
>
> http://blog.soebes.de/blog/2013/11/09/why-is-it-bad-to-activate-slash-deactive-modules-by-profiles-in-maven/
>
> Kind regards
> Karl Heinz Marbaise
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message