maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cintia Del Rio <miladyarte...@gmail.com>
Subject Re: deployAtEnd really works?
Date Thu, 14 May 2015 07:01:49 GMT
I was able to achieve similar results using this plugin:

https://github.com/sonatype/nexus-maven-plugins/tree/master/staging/maven-plugin

It's possible to disable the 'remote' staging and use only local staging -
it's called 'Deferred deploy'. Effectively it's the same as deployAtEnd.


The nexus staging plugin works with files to keep the state, so it's not
affected by the customised lifecycles.

On 14 May 2015 at 16:48, Dan Tran <dantran@gmail.com> wrote:

> Darn, I am using rpm-maven-plugin, and it has its own build lifecycle.
>
> what a bug.  It is  a very good feature
>
> Thanks
>
> -Dan
>
> On Wed, May 13, 2015 at 11:19 PM, Cintia Del Rio <miladyartemis@gmail.com>
> wrote:
>
> > Do you have a customised lifecycle plugin in your reactor?
> >
> > https://jira.codehaus.org/browse/MDEPLOY-176
> >
> >
> > On 14 May 2015 at 16:12, Dan Tran <dantran@gmail.com> wrote:
> >
> > > Hi Bernd ,
> > >
> > > I dont configure or execute any maven-deploy-plugin at my top level
> > parent
> > > pom.
> > >
> > > The only thing that I have which may not be very conventional:
> > >
> > > all of my modules are conditional activated by profile looking for
> > existing
> > > existing pom
> > >
> > >     <profile>
> > >       <id>enable-compX</id>
> > >       <activation>
> > >         <file>
> > >           <exists>components/compX/pom.xml</exists>
> > >         </file>
> > >       </activation>
> > >       <modules>
> > >         <module>components/compX</module>
> > >       </modules>
> > >     </profile>
> > >
> > >
> > > I am using Maven 3.2.3
> > >
> > > -Dan
> > >
> > >
> > > On Wed, May 13, 2015 at 10:56 PM, Bernd Eckenfels <
> > ecki@zusammenkunft.net>
> > > wrote:
> > >
> > > > Am Wed, 13 May 2015 22:47:15 -0700
> > > > schrieb Dan Tran <dantran@gmail.com>:
> > > >
> > > > > I am using this feature the first time and it does not seem to work
> > > > >
> > > > >   mvn clean deploy -DdeployAtEnd=true
> > > > >
> > > > > Each module displays this string at deploy phase
> > > > >
> > > > >  [INFO] *--- maven-deploy-plugin:2.8.2:deploy (default-deploy) @
> > > > > xxxxx*
> > > > >
> > > > > [INFO] Deploying xxxxx:0.0.1-SNAPSHOT at end
> > > > >
> > > > >
> > > > > Once the whole build is done, no deploy activity
> > > > >
> > > > >
> > > > > Am I missing any thing?
> > > >
> > > > Do you have a deploy plugin invocation in the aggregator pom?
> > > >
> > > > ---------------------------------------------------------------------
> > > > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > > > For additional commands, e-mail: users-help@maven.apache.org
> > > >
> > > >
> > >
> >
> >
> >
> > --
> > -------
> > Sent from TARDIS. Typos might be a timey whyney thingy.
> > Enviado da TARDIS, podem existir erros devido à diferenças de
> espaço-tempo.
> >
> > Cintia Del Rio
> >
>



-- 
-------
Sent from TARDIS. Typos might be a timey whyney thingy.
Enviado da TARDIS, podem existir erros devido à diferenças de espaço-tempo.

Cintia Del Rio

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message