maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason van Zyl <ja...@takari.io>
Subject Re: M2E and Eclipse Luna ?
Date Tue, 01 Jul 2014 14:41:05 GMT

On Jun 30, 2014, at 11:53 PM, Dan Tran <dantran@gmail.com> wrote:

> Hello Jason
> 
> which one  can we use to handle maven-plugin-plugin issue at Eclipse Luna?
> 

Not sure what you're referring to here.

> Possible to configure your nexus to use port 80 so that some of use with
> strict corp firewall policy can access it?
> 

Not anytime soon. I run everything with Jetty on specific ports right now. I'll take a look
at using Jetty on port 80 and acting as a front for the other services on the machine. This
is not particularly high on my priority list and I'm not installing Apache or NGinx as it
complicates the normals infrastructure I have.

> Thanks
> 
> -Dan
> 
> 
> 
> 
> On Fri, Jun 27, 2014 at 11:49 AM, Jason van Zyl <jason@takari.io> wrote:
> 
>> All the extras now live as separate installable units here:
>> 
>> http://repository.takari.io:8081/nexus/content/sites/m2e.extras/
>> 
>> On Jun 27, 2014, at 12:42 PM, Dan Tran <dantran@gmail.com> wrote:
>> 
>>> My apology,  should have been clearer
>>> 
>>> I installed Eclipse Luna and
>>> 
>> https://repository.sonatype.org/content/repositories/forge-sites/m2e-extras/0.15.0/N/0.15.0.201206251206
>>> 
>>> the message at the pom is "Plugin execution not covered by lifecycle
>>> configuration:
>> org.apache.maven.plugins:maven-plugin-plugin:3.2:descriptor
>>> (execution: default-descriptor, phase: process-classes)"
>>> 
>>> Thanks
>>> 
>>> -D
>>> 
>>> 
>>> 
>>> 
>>> On Fri, Jun 27, 2014 at 4:21 AM, Jason van Zyl <jason@takari.io> wrote:
>>> 
>>>> What exactly are you seeing? I have several plugins using the
>>>> "maven-plugin" packaging and they appear fine.
>>>> 
>>>> On Jun 26, 2014, at 11:15 PM, Dan Tran <dantran@gmail.com> wrote:
>>>> 
>>>>> I just try the latest eclipse and try to build exec-mojo-plugin at
>> MOJO,
>>>>> looks like m2e does not recognize maven-plugin-plugin
>>>>> 
>>>>> Any one else seeing this?
>>>>> 
>>>>> Thanks
>>>>> 
>>>>> -D
>>>> 
>>>> Thanks,
>>>> 
>>>> Jason
>>>> 
>>>> ----------------------------------------------------------
>>>> Jason van Zyl
>>>> Founder,  Apache Maven
>>>> http://twitter.com/jvanzyl
>>>> http://twitter.com/takari_io
>>>> ---------------------------------------------------------
>>>> 
>>>> Selfish deeds are the shortest path to self destruction.
>>>> 
>>>> -- The Seven Samuari, Akira Kurosawa
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>>>> 
>> 
>> Thanks,
>> 
>> Jason
>> 
>> ----------------------------------------------------------
>> Jason van Zyl
>> Founder,  Apache Maven
>> http://twitter.com/jvanzyl
>> http://twitter.com/takari_io
>> ---------------------------------------------------------
>> 
>> Three people can keep a secret provided two of them are dead.
>> 
>> -- Benjamin Franklin
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 
>> 

Thanks,

Jason

----------------------------------------------------------
Jason van Zyl
Founder,  Apache Maven
http://twitter.com/jvanzyl
http://twitter.com/takari_io
---------------------------------------------------------

Our achievements speak for themselves. What we have to keep track
of are our failures, discouragements and doubts. We tend to forget
the past difficulties, the many false starts, and the painful
groping. We see our past achievements as the end result of a
clean forward thrust, and our present difficulties as
signs of decline and decay.

 -- Eric Hoffer, Reflections on the Human Condition










Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message