maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Curtis Rueden <ctrue...@wisc.edu>
Subject Re: RSyntaxTextArea 2.5.1 and 2.5.2 to Maven Repo
Date Wed, 23 Apr 2014 16:13:19 GMT
Hi Kiran,

I was able to make your POM work by also explicitly adding the
rsyntaxtextarea dependency, which overrides the version:

    <dependency>
      <groupId>com.fifesoft</groupId>
      <artifactId>rsyntaxtextarea</artifactId>
      <version>${rsyntaxtextarea.version}</version>
      <scope>runtime</scope>
    </dependency>

HTH,
Curtis


On Wed, Apr 23, 2014 at 11:10 AM, Curtis Rueden <ctrueden@wisc.edu> wrote:

> Hi Kiran,
>
> The problem is that org.apache.jmeter:ApacheJMeter:2.11 declares a
> dependency (in its parent POM: org.apache.jmeter:ApacheJMeter_parent:2.11)
> on rsyntaxtextarea version 2.5.1, which has not available on Central yet:
>
>
> http://search.maven.org/#search%7Cgav%7C1%7Cg%3A%22com.fifesoft%22%20AND%20a%3A%22rsyntaxtextarea%22
>
> It declares the version in a property, so I was thinking you could fix it
> in your POM by adding:
>
> <properties>
> <rsyntaxtextarea.version>2.5.0</rsyntaxtextarea.version>
> </properties>
>
> But when I tested it, it didn't work for some reason. (Which is odd: I use
> the same trick for many of my projects, and it works just fine...)
>
> But anyway, it is a problem with JMeter: they shouldn't use an unavailable
> version of a dependency.
>
> Regards,
> Curtis
>
>
> On Wed, Apr 23, 2014 at 10:56 AM, KIRAN <rkkreddy@gmail.com> wrote:
>
>> Hi,
>>
>> Below is the POM xml I am using:
>>
>> ==============================================================
>> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
>> http://www.w3.org/2001/XMLSchema-instance"
>>   xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
>> http://maven.apache.org/maven-v4_0_0.xsd">
>>   <modelVersion>4.0.0</modelVersion>
>>   <groupId>com.example</groupId>
>>   <artifactId>jmeter-demo</artifactId>
>>   <packaging>jar</packaging>
>>   <version>1.0-SNAPSHOT</version>
>>   <name>jmeter-demo</name>
>>   <url>http://maven.apache.org</url>
>>   <dependencies>
>> <dependency>
>> <groupId>*org.apache.jmeter*</groupId>
>> <artifactId>*ApacheJMeter*</artifactId>
>> <version>*2.11*</version>
>> </dependency>
>>   <dependency>
>> <groupId>*kg.apc*</groupId>
>> <artifactId>*jmeter-plugins-webdrive*r</artifactId>
>> <version>*1.1.3*</version>
>> </dependency>
>>   </dependencies>
>>   <build>
>>   <plugins>
>> <plugin>
>> <groupId>*com.lazerycode.jmeter*</groupId>
>> <artifactId>*jmeter-maven-plugin*</artifactId>
>> <version>*1.9.0*</version>
>> <executions>
>> <execution>
>> <id>jmeter-tests</id>
>> <phase>verify</phase>
>> <goals>
>> <goal>jmeter</goal>
>> </goals>
>>    </execution>
>> </executions>
>> </plugin>
>> </plugins>
>> </build>
>> </project>
>> ==============================================================
>>
>> When I run mvn install, I am getting the below error:
>>
>> [ERROR] Failed to execute goal on project jmeter-demo: Could not resolve
>> dependencies for project com.example:jmeter-demo:jar:1.0-SNAPSHOT: Could
>> not find artifact com.fifesoft:rsyntaxtextarea:jar:2.5.1 in central
>> http://repo.maven.apache.org/maven2) -> [Help 1]
>>
>> Please help me in getting this issue resolved.
>> --
>> Regards,
>> Kirna
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message