maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Lynch <ply...@sonatype.com>
Subject Re: [nexus-user] Why are alternate repositories so hard to configure
Date Tue, 15 Apr 2014 13:50:26 GMT
Hello,

On Tue, Apr 15, 2014 at 12:14 AM, Eric Kolotyluk
<eric.kolotyluk@gmail.com>wrote:

>  I have the following
>
>       <repositories>
>         <repository>
>             <id>sonatype</id>
>             <name>Sonatype Maven OSS Repository</name>
>             <releases>
>                 <enabled>true</enabled>
>             </releases>
>             <snapshots>
>                 <enabled>true</enabled>
>             </snapshots>
>             <url>https://oss.sonatype.org/content/groups/public</url>
>         </repository>
>       </repositories>
>
> But when I run maven I get
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-site-plugin:3.3:site (default-site) on
> project csharp-windows-elevate: Execution default-site of goal
> org.apache.maven.plugins:maven-site-plugin:3.3:site failed: Plugin
> org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies
> could not be resolved: Could not find artifact
> net.trajano.wagon:wagon-git:jar:1.0.1-SNAPSHOT in apache.snapshots (
> http://repository.apache.org/snapshots) -> [Help 1]
>
> *Why in the world is it looking in http://repository.apache.org/snapshots
> <http://repository.apache.org/snapshots> ???*
>

This repository is defined in a pom.xml of a dependency.


>
>
> So, then I configure nexus to mirror
> https://oss.sonatype.org/content/groups/public and I add to my
> settings.xml
>
>   <mirrors>
>     <mirror>
>       <id>nexus</id>
>       <mirrorOf>*</mirrorOf>
>       <url>http://localhost:8081/nexus/content/groups/public</url>
>     </mirror>
>   </mirrors>
>
>
Good idea.


> and then I get
>
> [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-site-plugin:3.3:site (default-site) on
> project csharp-windows-elevate: Execution default-site of goal
> org.apache.maven.plugins:maven-site-plugin:3.3:site failed: Plugin
> org.apache.maven.plugins:maven-site-plugin:3.3 or one of its dependencies
> could not be resolved: Could not find artifact
> net.trajano.wagon:wagon-git:jar:1.0.1-SNAPSHOT in nexus (
> http://localhost:8081/nexus/content/groups/public) -> [Help 1]
>

apache-snapshots is not in the public group by default, although it is in
Nexus as a repository. You can edit the public group members and add
apache-snapshots as a member.




>
> I know this to be a lie because when I go through the nexus UI I can
> clearly see the artifact in question in both the nexus index and storage.
> However, for some reason, the artifact pom.xml is neither in the index nor
> storage. When I go to
> https://oss.sonatype.org/content/groups/public/net/trajano/wagon/wagon-git/1.0.1-SNAPSHOT/I
can clearly see the pom.xml with the other files that nexus has
> downloaded. *Why is nexus refusing to download the pom.xml?*
>

Search indexes have nothing to do with an artifact being able to be
downloaded.

In cases like this, these article may help you diagnose:

https://support.sonatype.com/entries/21437881-Troubleshooting-Artifact-Download-Failures


>
>
> Cheers, Eric
>
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message