maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Caradoc-Davies <Ben.Caradoc-Dav...@csiro.au>
Subject Re: Maven 3.2.1 and java 1.5?
Date Tue, 15 Apr 2014 01:45:22 GMT
On 14/04/14 16:07, delbert wrote:
> I need to use java 1.5.

Why? Please tell us more.

Is this is the only Java you have, or because you wish to generate 
bytecode that can run on Java 5? If the latter, you can configure source 
and target versions in the compiler.

It is still a good idea to compile with a genuine Java 5 to catch API 
changes (like new exception chaining constructors in Java 6) if you are 
targeting Java 5.

Kind regards,

-- 
Ben Caradoc-Davies <Ben.Caradoc-Davies@csiro.au>
Software Engineer
CSIRO Earth Science and Resource Engineering
Australian Resources Research Centre

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message