maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Caradoc-Davies <Ben.Caradoc-Dav...@csiro.au>
Subject Re: Maven 3.2.1 and java 1.5?
Date Mon, 14 Apr 2014 08:13:47 GMT
http://maven.apache.org/download.cgi
"System Requirements
JDK 	Maven 3.2 requires JDK 1.6 or above, while Maven 3.0/3.1 requires 
JDK 1.5 or above (this is to execute Maven - it still allows you to 
build against 1.3 and prior JDK's)"


On 14/04/14 16:07, delbert wrote:
> I need to use java 1.5. But when I run maven 3.2.1 I get:
>
> :~$ mvn --version
> Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad
> version number in .class file
> 	at java.lang.ClassLoader.defineClass1(Native Method)
> 	at java.lang.ClassLoader.defineClass(ClassLoader.java:621)
> 	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:
>
> If I change to java 1.7 it works. I have not been able to find in the
> release notes for 3.2.1 that java > 1.5 i s required.
>
> I can use java 5 and maven 3.1.1 just fine.
>
>
>
> --
> View this message in context: http://maven.40175.n5.nabble.com/Maven-3-2-1-and-java-1-5-tp5791274.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>
>

-- 
Ben Caradoc-Davies <Ben.Caradoc-Davies@csiro.au>
Software Engineer
CSIRO Earth Science and Resource Engineering
Australian Resources Research Centre

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message