maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Kennedy <davek1...@gmail.com>
Subject Re: Netbeans 7.4 maven POM for com.oracle:ojdbc6:jar:11.2.0.1 is invalid
Date Sun, 09 Mar 2014 00:35:19 GMT
The database and pom are on a remote server,
and the downloaded POM is not valid: 'modelVersion' is missing.

I don't have control over the server so I cannot change the POM.
Is there a way to have maven ignore the modelVersion is missing error?

<project>
    <groupId>com.oracle</groupId>
    <artifactId>ojdbc6</artifactId>
    <version>11.2.0.1</version>
</project>

Downloading:
http://newco.com/mvn_repository/com/oracle/ojdbc6/11.2.0.1/ojdbc6-11.2.0.1.pom
Checksum validation failed, no checksums available from the repository for
http://newco.com/mvn_repository/com/oracle/ojdbc6/11.2.0.1/ojdbc6-11.2.0.1.pom

Downloaded:
http://newco.com/mvn_repository/com/oracle/ojdbc6/11.2.0.1/ojdbc6-11.2.0.1.pom(114
B at 0.2 KB/sec)
Writing resolution tracking file
.m2\repository\com\oracle\ojdbc6\11.2.0.1\ojdbc6-11.2.0.1.pom.lastUpdated
Writing resolution tracking file
.m2\repository\com\oracle\ojdbc6\11.2.0.1\_maven.repositories
The POM for com.oracle:ojdbc6:jar:11.2.0.1 is invalid, transitive
dependencies (if any) will not be available: 1 problem was encountered
while building the effective model for com.oracle:ojdbc6:11.2.0.1
'modelVersion' is missing.

. . .
Internal Exception: java.sql.SQLException: No suitable driver found for
oracle:thin:@newco.com:1521:dbname

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message