maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wayne Fay <wayne...@gmail.com>
Subject Re: maven won't resolve from central log4j:log4j:1.2.8 through 1.2.15
Date Mon, 10 Mar 2014 13:15:52 GMT
>> Where did this repo.maven.apache.org url come from?
>
> Wayne, it's a correct URL for the central repository. It's the one we
> define in the super-POM since Maven 3.0.something.

Doh, well ignore that then. I should have done 30 seconds of searching
before sending that one. :)

But just FYI, when I myself tried accessing that URL last night, I had
problems in my browser. First it was HTTPS problems as the URL did not
match the server name being reported (I have the HTTPS Everywhere
plugin turned on). I clicked "ignore" and went to the site and got
HTTP 404 errors at /log4j/log4j/maven-metadata.xml so I moved up to
/log4j/log4j and had the same errors. I did not grab the error but it
was something related to Varnish cache - when I cause a 404 now, the
error appears different.

So at the very least, the mirror I was on (fastly.net) was having
issues - and potentially this was mirrored to others, possibly
explaining the troubles (??). I had no such trouble hitting the old
standby of repo1.maven.org and resolving the files etc. These errors
made me question the URL entirely.

I hit it again just now and dns sends me to fastly.net again but this
time the files are there.

So, I would ask Richard to try again and see if things work better
today, or if he is having the same troubles.

Wayne

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message