maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stuart McCulloch <mccu...@gmail.com>
Subject Re: Looking for org.apache.poi 3.10-FINAL
Date Sun, 16 Feb 2014 15:20:20 GMT
On 16 February 2014 14:36, David Law <m2eclipse@apconsult.de> wrote:

> Hi Stuart,
>
> thanks for that very useful information.
> Are you using the default repo?
> (http://repo.maven.apache.org/maven2)
>

I switch depending what workspace I'm using, as I have a corporate repo as
well as a local nexus instance (enabled to download remote indexes)

But I just tried from a fresh installation with the default repo to confirm
and it is in the latest index with nexus.index.timestamp=20140216125157.106


> All the best,
> DaveLaw
>
> On 16.02.2014 14:36, Stuart McCulloch wrote:
>
>> On 16 February 2014 10:31, David Law <m2eclipse@apconsult.de> wrote:
>>
>>  Hi Mirko,
>>>
>>> I think though 6 days!!! should be adequate for that.
>>> In fact, I think 6 minutes should be adequate.
>>>
>>> So I really need someone to explain how I can move forward with this
>>> issue.
>>>
>>>  FWIW, I did a search today for org.apache.poi:poi in my local m2e
>> and 3.10-FINAL appeared - so it's definitely in the index from the 15th
>> (which is the index downloaded on my local computer according to the file
>> under .metadata/.plugins/org.eclipse.m2e.core/nexus), but not sure when
>> it
>> was indexed...
>>
>> You could always post a question on
>> https://issues.sonatype.org/browse/MVNCENTRAL if you want a definitive
>> answer of what happened, when, and why.
>>
>> All the best,
>>
>>> DaveLaw
>>>
>>>
>>> On 16.02.2014 10:49, Mirko Friedenhagen wrote:
>>>
>>>  David,
>>>>
>>>> just guessing:
>>>> - indexing takes it's time, there are only two hours difference between
>>>> the
>>>> commit (??l and end of indexing.
>>>> - commit (tag creation), artifact creation (jar build), deployment
>>>> (upload
>>>> to staging),  promotion (move of staged to released) and synchronization
>>>> from oss.sonatype.org to repo1 add delays :-)
>>>>
>>>> Regards
>>>> Mirko
>>>>
>>>>  On 16.02.2014 09:43, David Law wrote:
>>>
>>>  Hi,
>>>>
>>>> I'm new to maven & thought I'd try it out on the recently checked-in:
>>>> org.apache.poi    3.10-FINAL
>>>>
>>>> I'm using m2eclipse standard config with Eclipse Kepler.  Repo defaults
>>>> to:
>>>> http://repo.maven.apache.org/maven2
>>>>
>>>> The Problem:
>>>> m2eclipse does not know the  org.apache.poi  3.10-FINAL  artifact.
>>>>
>>>> Now, I guess the problem could be any combination of:
>>>> a) me  b) POI  c) maven  d) m2eclipse  e) eclipse?
>>>>
>>>> QUESTION) Can anyone help to localise it?
>>>>
>>>> Here's what I've found out so far:
>>>>
>>>> 0) repo is: http://repo.maven.apache.org/maven2
>>>>
>>>> 1) org.apache.poi  3.10-FINAL was committed @ 09-Feb-2014 11:50
>>>>
>>>> 2) as of now repo Timestamp is: 09-Feb-2014 13:50
>>>> (nexus.index.timestamp=20140209134945.568 +0000)
>>>> (found in
>>>> http://repo.maven.apache.org/maven2/.index/nexus-maven-
>>>> repository-index.properties)
>>>>
>>>> 3) -> so repo has been reindexed since org.apache.poi 3.10-FINAL commit
>>>> (6 days ago).
>>>>
>>>> 4) exit eclipse
>>>>
>>>> 5) deleted the index
>>>> C:\...\Eclipse\workspace\.metadata\.plugins\org.eclipse.m2e.core\nexus
>>>>
>>>> 6) start eclipse -> "updating index"
>>>>
>>>> 7) org.apache.poi  3.10-FINAL is still not there (that is: "here") in my
>>>> list of artifacts
>>>>
>>>> All the best,
>>>> DaveLaw
>>>>
>>>
-- 
Cheers, Stuart

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message