maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rahulmishramail <rahul.mish...@wipro.com>
Subject Re: Maven / Java 1.7 compliance
Date Mon, 13 Jan 2014 05:09:51 GMT
Hi Johannes

For a long time, i was facing the same issue. But i finally got the
solution.
If you are using maven version 3.0.4 or above, then certainly your code will
compile in 1.7. Just add the below two properties in the <properties>
section of your project Pom file.

<maven.compiler.source>1.7</maven.compiler.source>
<maven.compiler.target>1.7</maven.compiler.target>

The code will compile fine in 1.7. Please see the below link for further
info.
http://stackoverflow.com/questions/8750563/maven-doesnt-use-java-7

P.S : If you are using maven version prior to 3.0.4 version, than there will
be a compilation issue. So, better you update your maven version.


Regards
Rahul
Contact : +91-9540488347



--
View this message in context: http://maven.40175.n5.nabble.com/Maven-Java-1-7-compliance-tp5124043p5781227.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message