maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Derricutt" <m...@talios.com>
Subject maven-release-plugin oddity - no git commit under mvn 3.1.1
Date Mon, 09 Dec 2013 02:40:19 GMT
Hey all,

Just encountered a strange issue with the maven-release-plugin, when doing a release:prepare
from my machine using Maven 3.1.1, and maven-release-plugin 2.4.2 I get the following output:

[INFO] Checking in modified POMs...
[INFO] Executing: /bin/sh -c cd /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
&& git add -- pom.xml
[INFO] Working directory: /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
[INFO] Executing: /bin/sh -c cd /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
&& git status
[INFO] Working directory: /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
[INFO] Tagging release with the label com.smxemail.translation-13.2.9...
[INFO] Executing: /bin/sh -c cd /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
&& git tag -F /var/folders/bq/jtxn4t511xz7l_t3t4q4c6340000gn/T/maven-scm-596385603.commit
com.smxemail.translation-13.2.9
[INFO] Working directory: /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
[INFO] Executing: /bin/sh -c cd /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
&& git ls-files
[INFO] Working directory: /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
[INFO] Transforming 'com.smxemail.translation'...
[INFO] Not removing release POMs
[INFO] Checking in modified POMs...
[INFO] Executing: /bin/sh -c cd /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
&& git add -- pom.xml
[INFO] Working directory: /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
[INFO] Executing: /bin/sh -c cd /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
&& git status
[INFO] Working directory: /Users/amrk/IdeaProjects/securemx/smx3/com.smxemail.translation
[INFO] Release preparation complete.
[INFO] ------------------------------------------------------------------------
[INFO] BUILD SUCCESS

You can see here that there are no "git commit" commands being run, this in turn breaks the
build.

A coworker who is still using Maven 3.0.4 was able to prepare and release the artefact fine
however, so I'm wondering if there's some issue at the SCM layer of maven that's breaking
when running under 3.1.1 that isn't an issue when using 3.0.4.

Has anyone else seen any behaviour like this?

Mark

Mime
View raw message