maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Dix <John....@amdocs.com>
Subject RE: plugin version ranges errors with Maven 3.1.1
Date Fri, 06 Dec 2013 22:20:01 GMT
We are getting build failures when using 3.1.1 and the 2.0 shade plugin. It seems to be a documented
issue:

https://issues.apache.org/jira/browse/STANBOL-1212

So I wanted to be able to have the same parent pom for our builds that still require 3.0.5
which currently sets it to 2.0 and does not run into this error.

-----Original Message-----
From: Wayne Fay [mailto:waynefay@gmail.com] 
Sent: Friday, December 06, 2013 12:51 PM
To: Maven Users List
Subject: Re: plugin version ranges errors with Maven 3.1.1

> Agreed however I need to support two builds in our environment one 
> that uses Maven 3.0.5 and one that does 3.1.1 without having to change the file every
time.

Sorry for asking the obvious question, but what prevents you from specifying version [2.0]
or whatever and using that with both 3.0.5 and 3.1.1? Is there some incompatibility I am unaware
of presently?

Wayne

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


This message and the information contained herein is proprietary and confidential and subject
to the Amdocs policy statement,
you may review at http://www.amdocs.com/email_disclaimer.asp
Mime
View raw message