maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alejandro.E...@miranda.com
Subject Re: deplot at end not working
Date Fri, 08 Nov 2013 18:36:23 GMT
Thank you Andreas and Robert. That was probably the problem. That also 
explains why there were like 4 artifacts (our of ~300) that did get 
deployed.

Two questions:
1) is there an open bug already for this known issue? i would like to 
follow it
2) Why is this the current behaviour? shouldn't it just fail the build as 
soon as it detects a version mismatch? i've never seen a similar behaviour 
in maven where you ask it to do something (deploy), it doesn't do it, but 
finishes successfully

Alejandro Endo | Software Designer/Concepteur de logiciels




From:   "Robert Scholte" <rfscholte@apache.org>
To:     "Maven Users List" <users@maven.apache.org>, 
Date:   2013-11-08 12:42 PM
Subject:        Re: deplot at end not working



There are still a small number of cases where the *AtEnd doesn't work, so 
I'm still glad I didn't made it the default behavior.
Most important is that all modules must use exactly the same version of 
either the maven-install-plugin or maven-deploy-plugin, otherwise the 
plugin can't keep track of the number of processed projects.
If it is still an issue and you can reproduce it with a small multimodule 
example, upload it with a new JIRA issue, just like MINSTALL-102[1]
Other examples of integration tests can be found in subversion[2]

Robert

[1] https://jira.codehaus.org/browse/MINSTALL-102
[2] 
http://svn.apache.org/repos/asf/maven/plugins/trunk/maven-install-plugin/src/it/


Op Fri, 08 Nov 2013 18:21:20 +0100 schreef <Alejandro.Endo@miranda.com>:

> I'm using m-d-p 2.8.1 using the new deploy at end config. I also use
> install at end in the m-i-p. However, what I see is that sometimes the
> artifacts are not installed nor deployed at all.
> I see the normal execution of the plugins with the ** will be deployed 
at
> end in both cases. But comparing the cases when it does work and when it
> doesn't, when it does I see a final invocation to m-d-p where the deploy
> happens. This last invocation sometimes doesn't happen. I have -X logs 
> for
> both cases but the case where it doesn't work, the build is like
> 200modules so the log is 150MB
>
> I'm using differential builds in jenkins (mvn -amd -pl ) in the one that
> worked, and it built and deployed like 10artifacts that changed. But 
when
> I run it without -amd -pl, i.e. a full build, it never deploys nor
> installs at end
>
>
> This is the last part of when it doesn't work (some obfuscations done)
>
> [DEBUG]   (f) retryFailedDeploymentCount = 1
> [DEBUG]   (f) skip = false
> [DEBUG]   (f) updateReleaseInfo = false
> [DEBUG]   (f) project = MavenProject: com.tools:blah:1.0.0-SNAPSHOT @
> /var/lib/jenkins/workspace/blah/tools/upgrade/pom.xml
> [DEBUG] -- end configuration --
> [INFO] Deploying com.tools:blah:1.0.0-SNAPSHOT at end
> projectSucceeded com.tools:blah:1.0.0-SNAPSHOT
> sessionEnded
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> ....
>
>
> when it does work i see at the end the deploy plugin running
>
> Uploaded: http://someUrl/maven-metadata.xml (415 B at 1.0 KB/sec)
> mojoSucceeded
> org.apache.maven.plugins:maven-deploy-plugin:2.8.1(default-deploy)
> projectSucceeded com.tools.other:foo.1.0.0-SNAPSHOT
> sessionEnded
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> ...
>
>
> Is this a known issue or am I doing something wrong?
>
> Let me know if someone needs more details
>
> Thank you,
> Alejandro Endo | Software Designer/Concepteur de logiciels
>
> DISCLAIMER:
> Privileged and/or Confidential information may be contained in this
> message. If you are not the addressee of this message, you may not
> copy, use or deliver this message to anyone. In such event, you
> should destroy the message and kindly notify the sender by reply
> e-mail. It is understood that opinions or conclusions that do not
> relate to the official business of the company are neither given
> nor endorsed by the company.
> Thank You.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org



DISCLAIMER:
Privileged and/or Confidential information may be contained in this
message. If you are not the addressee of this message, you may not
copy, use or deliver this message to anyone. In such event, you
should destroy the message and kindly notify the sender by reply
e-mail. It is understood that opinions or conclusions that do not
relate to the official business of the company are neither given
nor endorsed by the company.
Thank You.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message