maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hervé BOUTEMY <herve.bout...@free.fr>
Subject Re: Maven Site Plugin 3.1
Date Mon, 11 Nov 2013 16:03:41 GMT
I suppose you're using Maven 3.1.x

you should read 
https://cwiki.apache.org/confluence/display/MAVEN/AetherClassNotFound then 
upgrade plugins versions accordingly

or use Maven 3.0.x

Regards,

Hervé

Le lundi 11 novembre 2013 09:38:40 Collins Solutions a écrit :
> I am trying to use the maven site plugin 3.1 and I get this error:
> 
> Failed to execute goal
> org.apache.maven.plugins:maven-site-plugin:3.1:site (default-site) on
> project acc-eao: Execution default-site of goal
> org.apache.maven.plugins:maven-site-plugin:3.1:site failed: A required
> class was missing while executing
> org.apache.maven.plugins:maven-site-plugin:3.1:site:
> org.sonatype.aether.graph.DependencyFilter
> 
> I am not trying to use sonatype at the moment.  My site plugin
> configuration looks like this:
> 
> ...
>              <plugin>
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-site-plugin</artifactId>
>                  <version>3.1</version>
>                  <executions>
>                      <execution>
>                          <id>attach-descriptor</id>
>                          <goals>
> <goal>attach-descriptor</goal>
>                          </goals>
>                      </execution>
>                  </executions>
>              </plugin>
> ...
> 
> ...
>   <profiles>
>          <profile>
>              <id>full</id>
>              <reporting>
>                  <plugins>
>                      <!-- Java Documentation -->
>                      <plugin>
> <groupId>org.apache.maven.plugins</groupId>
> <artifactId>maven-javadoc-plugin</artifactId>
> <version>${javadoc.version}</version>
>                      </plugin>
>                  </plugins>
>              </reporting>
>          </profile>
>      </profiles>
> ...
> 
> I have been having various other issues with the site plugin that I was
> not having with version 2.x.  One question that I have is, is it
> required to have a site.xml file now?  Before, i did not need to include
> any site configuration to get a site generated however, that
> configuration (or lack thereof) did not work with version 3.1.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message