maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: Maven Version 3.0.4 compatibility with Java Version
Date Wed, 02 Oct 2013 06:19:11 GMT
This is controlled by the maven-compiler-plugin. The version of that plugin
that Maven 3.0.4 uses by default uses Java 5 by default. So you must either
have an older version of the plugin defined or a configuration of that
plugin stating Java 1.3.
If you check the effective-pom it should be "easy" to tell.

/Anders


On Wed, Oct 2, 2013 at 5:45 AM, Raghavendra Nandagopal <
speaktoraghav@gmail.com> wrote:

> Hi,
>   The maven version I am using is Maven 3.0.4.  When I try to compile a
> Java project, the error that states is "enums are not supported in -source
> 1.3
> (use -source 5 or higher to enable enums)".
>
>   My java version is JDK 7.0 and the JAVA_HOME variable is set correctly
> and part of the build path.
>
>   I understand that the java version has to be configured in the pom.xml
> for the project to make use of JDK 7.0.
> The clarification I needed is if Maven version 3.0.4 then isn't by default
> uses JDK 5.0 and above?
> I don't need to change the value for each and every pom.xml for the
> projects that I work.
> Please let me know if you have any workaround.
>
> Thanks,
> Raghavendra Nandagopal
>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: users-unsubscribe@maven.**apache.org<users-unsubscribe@maven.apache.org>
> For additional commands, e-mail: users-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message