maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Connolly <stephen.alan.conno...@gmail.com>
Subject Re: Detected Maven Version: 2.2.1 is not in the allowed range [3.0.2,)
Date Fri, 25 Oct 2013 10:26:20 GMT
FTR, here is the standard requires I add to most of my projects:

                  <requireMavenVersion>

                    <version>(,2.1.0),(2.1.0,2.2.0),(2.2.0,)</version>

                    <message>Maven 2.1.0 and 2.2.0 produce incorrect GPG
signatures and checksums respectively.

                    </message>

                  </requireMavenVersion>

                  <requireMavenVersion>

                    <version>(,3.0),[3.0.4,)</version>

                    <message>Maven 3.0 through 3.0.3 inclusive do not pass
correct settings.xml to Maven Release

                      Plugin.

                    </message>

                  </requireMavenVersion>

Hadoop are not as forgiving as me it would seem




On 25 October 2013 11:23, Stephen Connolly
<stephen.alan.connolly@gmail.com>wrote:

> The people who write the software you are trying to build have decreed
> that you need to use a recent version of Maven in order to build correctly.
> They have defined an enforcer rule to enforce their minimum maven version
> requirement. The enforcer rule has kicked in and failed the build early
> because you are using maven version 2.2.1 and the allowed range is [3.0.2,)
>
> Maven has a version range syntax. briefly
>
> [x] means only version x and no other version
>
> [x,y] means any version >=x and <=y
>
> [x,y) means any version >=x and <y
>
> (x,y] means any version >x and <=y
>
> (x,y) means any version >x and <y
>
> (,x] means any version <=x
>
> [x,) means any version >=x
>
> (,x) means any version <x
>
> (x,) means any version >x
>
>
> HTH
>
>
> On 25 October 2013 07:46, rushikeshgaradade@gmail.com <
> rushikeshgaradade@gmail.com> wrote:
>
>> Hi,
>>      i am very new to maven. I am trying to import hadoop source code into
>> eclipse. and for this i followed this link:
>> http://wiki.apache.org/hadoop/EclipseEnvironment
>>
>> in this there are 2 mvn commands:
>>  $ mvn install -DskipTests
>> $ mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true
>>
>>
>> during both command execution i came across following error
>>
>> [INFO] [enforcer:enforce {execution: default}]
>> [WARNING] Rule 0: org.apache.maven.plugins.enforcer.RequireMavenVersion
>> failed with message:
>> *Detected Maven Version: 2.2.1 is not in the allowed range [3.0.2,).*
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Some Enforcer rules have failed. Look above for specific messages
>> explaining why the rule failed.
>>
>>
>> Highlighted one is main area of interest which i didn't understood.(i have
>> installed maven2) Please can u help me in solving above query.
>>
>> Thank You
>>
>>
>>
>> --
>> View this message in context:
>> http://maven.40175.n5.nabble.com/Detected-Maven-Version-2-2-1-is-not-in-the-allowed-range-3-0-2-tp5773798.html
>> Sent from the Maven - Users mailing list archive at Nabble.com.
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message