maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jennifer Vendetti <>
Subject mvn-eclipse-plugin problem with pde projects and linked resources
Date Wed, 23 Oct 2013 19:45:06 GMT

I just took over the maintenance of several OSGi bundles.  I added the 
mvn-eclipse-plugin to the POM files for each of the bundles because I'd 
like to generate the necessary Eclipse project files to work with the 
source code and use the OSGi Framework launcher in the Eclipse IDE:


For reasons I don't understand, running "mvn eclipse:eclipse" generates 
a .project file with an incomplete set of linked resources.  For 
example, I have a POM file for one of the bundles that has the following 
3 dependencies:




The generated .project file for this bundle only has one linked resource 
to one of the artifacts:

<?xml version="1.0" encoding="UTF-8"?>
   <comment>Core Protege Libraries. NO_M2ECLIPSE_SUPPORT: Project files 
created with the maven-eclipse-plugin are not supported in 

When I try to import the existing PDE project into Eclipse, I get 
compiler errors since the other two artifacts aren't listed as linked 

Is there something I'm missing about how to properly use this plug-in?  
I'm using Maven version 3.1.0.  Any help and/or advice would be very 
much appreciated.


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message