maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rushikeshgaradade@gmail.com" <rushikeshgarad...@gmail.com>
Subject Detected Maven Version: 2.2.1 is not in the allowed range [3.0.2,)
Date Fri, 25 Oct 2013 06:46:44 GMT
Hi, 
     i am very new to maven. I am trying to import hadoop source code into
eclipse. and for this i followed this link: 
http://wiki.apache.org/hadoop/EclipseEnvironment 

in this there are 2 mvn commands: 
 $ mvn install -DskipTests
$ mvn eclipse:eclipse -DdownloadSources=true -DdownloadJavadocs=true


during both command execution i came across following error

[INFO] [enforcer:enforce {execution: default}]
[WARNING] Rule 0: org.apache.maven.plugins.enforcer.RequireMavenVersion
failed with message:
*Detected Maven Version: 2.2.1 is not in the allowed range [3.0.2,).*
[INFO]
------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO]
------------------------------------------------------------------------
[INFO] Some Enforcer rules have failed. Look above for specific messages
explaining why the rule failed.


Highlighted one is main area of interest which i didn't understood.(i have
installed maven2) Please can u help me in solving above query. 

Thank You



--
View this message in context: http://maven.40175.n5.nabble.com/Detected-Maven-Version-2-2-1-is-not-in-the-allowed-range-3-0-2-tp5773798.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message