maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 禹航 <unbounder.tr...@gmail.com>
Subject Maven Assembly plugin is not working when install
Date Sun, 01 Sep 2013 18:50:44 GMT
hi there,
   i try to user maven-assembly plugin to generate a tar.gz.my pom is like
this:
*        <pluginManagement>
            <plugins>
                <plugin>
                    <groupId>org.apache.maven.plugins</groupId>
                    <artifactId>maven-assembly-plugin</artifactId>
                    <configuration>
                        <finalName>tauras-master</finalName>
                        <descriptors>

<decriptor>src/main/assembly/assembly-offline.xml</decriptor>
                        </descriptors>
                    </configuration>
                    <executions>
                        <execution>
                            <id>make-assembly</id>
                            <phase>package</phase>
                            <goals>
                                <goal>single</goal>
                            </goals>
                        </execution>
                    </executions>
                </plugin>
            </plugins>
        </pluginManagement>*

when i use assembly:single, it works well.
but when i use install or package, the result is wrong
the output of the console:

[INFO]
[INFO] --- maven-clean-plugin:2.4.1:clean (default-clean) @ tauras-master
---
[INFO] Deleting E:\svn\taurus\tauras-master\target
[INFO]
[INFO] --- maven-resources-plugin:2.5:resources (default-resources) @
tauras-master ---
[debug] execute contextualize
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] Copying 1 resource
[INFO] Copying 1 resource
[INFO]
[INFO] --- maven-compiler-plugin:2.5.1:compile (default-compile) @
tauras-master ---
[INFO] Compiling 5 source files to
E:\svn\taurus\tauras-master\target\classes
[INFO]
[INFO] --- maven-resources-plugin:2.5:testResources (default-testResources)
@ tauras-master ---
[debug] execute contextualize
[INFO] Using 'UTF-8' encoding to copy filtered resources.
[INFO] skip non existing resourceDirectory
E:\svn\taurus\tauras-master\src\test\resources
[INFO]
[INFO] --- maven-compiler-plugin:2.5.1:testCompile (default-testCompile) @
tauras-master ---
[INFO] Not compiling test sources
[INFO]
[INFO] --- maven-surefire-plugin:2.7.2:test (default-test) @ tauras-master
---
[INFO] Tests are skipped.
[INFO]
[INFO] --- maven-jar-plugin:2.4:jar (default-jar) @ tauras-master ---
[INFO] Building jar: E:\svn\taurus\tauras-master\target\tauras-master.jar
*missing
[INFO] --- maven-assembly-plugin:2.2-beta-5:single (make-assembly) @
**tauras-master ---
[INFO] Reading assembly descriptor: src/main/assembly/assembly-offline.xml
missing*
[INFO]
[INFO] --- maven-install-plugin:2.3.1:install (default-install) @
tauras-master ---

Any comments for this?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message