maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Boston <ianbos...@gmail.com>
Subject Problem with maven shared invoker.
Date Sat, 03 Aug 2013 07:23:28 GMT
Hi,

Question:
How do I make the DefaultInvoker.executeCommandLine in [2] log the command line

in version 2.0.11 of executeCommandLine there is

if ( getLogger().isDebugEnabled() )
        {
            getLogger().debug( "Executing: " + cli );
        }


I have tried

-X

-Dinvoker.debug=true

-Dmaven.invoker.debug=true


and configuring maven-invoker-plugin with <debug>true</debug> in the


I have also tried to break the invoker, but nothing I do makes any difference


Detail:

Over in Apache Sling my GSoC Student is struggling to build Sling, It
builds for everyone else but him. The log is at [1]. He is running as
root, (bad), in a users home folder, and I have asked him to try
again. He is trying to build tooling/maven/archetypes/servlet from
sling trunk.

eg

svn co https://svn.apache.org/repos/asf/sling/trunk
cd  tooling/maven/archetypes/servlet
mvn clean install

Looking at the output and the source code it looks like the maven
shared invoker is failing to launch a new copy of maven from the
command line. I believe the code being used is [2].

Based on looking at the difference between a successful build and a
failing build the invoker never manages to invoke the maven command. I
would like to be able to give him a simple patch, he can apply so we
can see what is going on on his box.

He has been blocked for 2 weeks by this issue.

Best Regards
Ian


1 http://pastebin.com/9gsHxfFZ
2 http://jarvana.com/jarvana/view/org/apache/maven/shared/maven-invoker/2.0.11/maven-invoker-2.0.11-sources.jar!/org/apache/maven/shared/invoker/DefaultInvoker.java?format=ok

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message