maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Broyer <t.bro...@gmail.com>
Subject Re: Error when loading dependency on a personal repository
Date Sat, 17 Aug 2013 14:12:52 GMT
The error is in resolving the dependency, not deploying it. So I'd say the
error is the missing ":" in the repository URL.
Le 12 août 2013 15:12, "Baptiste Mathus" <ml@batmat.net> a écrit :

> Hi,
> Sure Tomcat isn't required (btw, Apache Httpd also supports webdav).
>
> From the error excerpt you provided("http//", not ftp and missing ":" ?), I
> suppose you didn't configure correctly your distributionManagement.
> Deploying to ftp is indeed supported. Did you correctly declare the
> wagon-ftp extension, like described here:
>
> http://maven.apache.org/plugins/maven-deploy-plugin/examples/deploy-ftp.html
>
> Could you show us your pom (putting it on some place like pastebin or
> gist@github), or even better a test project?
>
> Cheers
>
>
> 2013/8/9 Manuel Dahmen <manuel.dahmen@gmail.com>
>
> >
> > I configured wagon extension to push over ftp.
> >
> > I have sources under scm mercurial.
> >
> > And I have declared a distributionManagement
> >
> > Really, I don't understand.
> >
> > Do I really need a public Tomcat server? Because I use Apache and ftp.
> > -----Message d'origine-----
> > De : SARTAJ HUNDAL [mailto:vektor.knight@gmail.com]
> > Envoyé : vendredi 9 août 2013 23:07
> > À : Maven Users List
> > Objet : Re: Error when loading dependency on a personal repository
> >
> > On 13-08-09 03:03 PM, Manuel Dahmen wrote:
> > >
> > > I try to publicize my project.
> > >
> > > I have two projects that I compile tonight.
> > >
> > > The dependency compiles and uploads on mysite.be
> > >
> > > But the dependent myproject doesn't download the dependency.
> > >
> > > [ERROR] Failed to execute goal on project emptycanvas: Could not
> > > resolve depende
> > >
> > > ncies for project be.mysite:myproject:pom:17.0: Could not transfer
> > > artifact
> > >
> > > com.otherproject:OtherLibrary:jar:0.7.7-STABLE from/to be.mysite
> > > (http//www.mysite.be): No connector available to access repository be.
> > > mysite (http//ww
> > >
> > > w. mysite.be) of type legacy using the available factories
> > > WagonRepositoryConn
> > >
> > > ectorFactory -> [Help 1]
> > >
> > > [ERROR]
> > >
> > > *-------*
> > >
> > > *-  0 0 -*
> > >
> > > *-*/\*-*
> > >
> > > *_-  ~~ -_*
> > >
> > Have you configured the correct tunnelling protocol before you push it?
> >
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > For additional commands, e-mail: users-help@maven.apache.org
> >
> > --
> > Baptiste <Batmat> MATHUS - http://batmat.net
> > Sauvez un arbre,
> > Mangez un castor ! nbsp;! <users-help@maven.apache.org>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message