maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manuel Dahmen" <manuel.dah...@gmail.com>
Subject RE: Error when loading dependency on a personal repository
Date Fri, 09 Aug 2013 21:23:56 GMT

I configured wagon extension to push over ftp.

I have sources under scm mercurial.

And I have declared a distributionManagement

Really, I don't understand.

Do I really need a public Tomcat server? Because I use Apache and ftp.
-----Message d'origine-----
De : SARTAJ HUNDAL [mailto:vektor.knight@gmail.com] 
Envoyé : vendredi 9 août 2013 23:07
À : Maven Users List
Objet : Re: Error when loading dependency on a personal repository

On 13-08-09 03:03 PM, Manuel Dahmen wrote:
>
> I try to publicize my project.
>
> I have two projects that I compile tonight.
>
> The dependency compiles and uploads on mysite.be
>
> But the dependent myproject doesn't download the dependency.
>
> [ERROR] Failed to execute goal on project emptycanvas: Could not 
> resolve depende
>
> ncies for project be.mysite:myproject:pom:17.0: Could not transfer 
> artifact
>
> com.otherproject:OtherLibrary:jar:0.7.7-STABLE from/to be.mysite
> (http//www.mysite.be): No connector available to access repository be. 
> mysite (http//ww
>
> w. mysite.be) of type legacy using the available factories 
> WagonRepositoryConn
>
> ectorFactory -> [Help 1]
>
> [ERROR]
>
> *-------*
>
> *-  0 0 -*
>
> *-*/\*-*
>
> *_-  ~~ -_*
>
Have you configured the correct tunnelling protocol before you push it?



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message