maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roger Brechb├╝hl <rotscher...@gmail.com>
Subject Re: Maven assembly single goal not works.
Date Wed, 31 Jul 2013 08:52:24 GMT
when calling assembly:single only, the package phase and all its attached
plugins are not executed. Especially, the maven-jar-plugin is not executed,
so no jar file is generated and attached. Hence the error message.

mvn package single:assembly (which is needless with your configuration if
you don't remove the executions part)

Cheers,
Rotsch



2013/7/31 Tim Wu T <tim.t.wu@ericsson.com>

> HI there,
>
> I try to use the assembly single goal to generate a jar with dependencies,
> my config looks like this:
>                      <plugin>
>                            <artifactId>maven-assembly-plugin</artifactId>
>                            <version>2.3</version>
>                            <configuration>
>                                   <archive>
>                                          <manifest>
>
> <mainClass>org.testng.TestNG</mainClass>
>                                          </manifest>
>                                   </archive>
>                                   <descriptorRefs>
>
>  <descriptorRef>jar-with-dependencies</descriptorRef>
>                                   </descriptorRefs>
>                            </configuration>
>                            <executions>
>                                   <execution>
>                                          <id>make-assembly</id> <!-- this
> is used for inheritance merges -->
>                                          <phase>package</phase> <!-- bind
> to the packaging phase -->
>                                          <goals>
>                                                 <goal>single</goal>
>                                          </goals>
>                                   </execution>
>                            </executions>
>                      </plugin>
>
> I can use the mvn clean install to generate jar with dependnecies well,
> but if I want to try assembly:single, than it will show me
> Cannot include project artifact: xxxxxx; it doesn't have an associated
> file or directory.
>
> Any comments for this?
>
> Br,
> Tim
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message