maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brian Fox <bri...@infinity.nu>
Subject Re: bad request return code from Sonatype doing release:perform
Date Mon, 29 Jul 2013 17:05:32 GMT
Looking at the logs, it appears that you are trying to actually stage
the parent, not your project. You don't have permissions to stage the
oss parent, hence the error.

On Fri, Jul 19, 2013 at 8:25 AM, Richard Sand <rsand@idfconnect.com> wrote:
> Hi all - trying to get my first plugin released into Maven Central. The
> snapshot is there, and release:prepare executed fine.
>
> When I run release:perform, I'm getting a 400-Bad Request error when maven
> tries to download something from the Sonatype parent when I do the release.
> Has anyone seen this error? Since all of the reports/site plugin ran
> successfully on the snapshot, does it matter if I just disable them for the
> release goal? I've got a ticket open with Sonatype but thought someone on
> the list may have encountered this before.
>
>   [INFO] <<< maven-plugin-plugin:3.2:report (report:report) @
> idfc-proguard-maven-plugin <<<
>     [INFO] Parent project loaded from repository:
> org.sonatype.oss:oss-parent:pom:7
>     Downloading:
> https://oss.sonatype.org/service/local/staging/deploy/maven2/org/sonatype/os
> s/oss-parent/7/oss-parent-7-site_en.xml
>     [INFO]
> ------------------------------------------------------------------------
>     [INFO] BUILD FAILURE
>     [INFO]
> ------------------------------------------------------------------------
>     [INFO] Total time: 31.175s
>     [INFO] Finished at: Thu Jul 18 10:16:19 EDT 2013
>     [INFO] Final Memory: 31M/75M
>     [INFO]
> ------------------------------------------------------------------------
>     [ERROR] Failed to execute goal
> org.apache.maven.plugins:maven-site-plugin:3.3:site (default-site) on
> project idfc-proguard-maven-plugin: SiteToolException: The site descriptor
> cannot be resolved from the repository: ArtifactResolutionException: Unable
> to locate site descriptor: Could not transfer artifact
> org.sonatype.oss:oss-parent:xml:site_en:7 from/to oss.sonatype.org
> (https://oss.sonatype.org/service/local/staging/deploy/maven2/): Failed to
> transfer file:
> https://oss.sonatype.org/service/local/staging/deploy/maven2/org/sonatype/os
> s/oss-parent/7/oss-parent-7-site_en.xml. Return code is: 400 ,
> ReasonPhrase:Bad Request.
>     [ERROR] org.sonatype.oss:oss-parent:xml:7
>     [ERROR]
>     [ERROR] from the specified remote repositories:
>     [ERROR] oss.sonatype.org
> (https://oss.sonatype.org/service/local/staging/deploy/maven2/,
> releases=true, snapshots=true),
>     [ERROR] sonatype-nexus-snapshots
> (https://oss.sonatype.org/content/repositories/snapshots, releases=false,
> snapshots=true),
>     [ERROR] central (http://repo.maven.apache.org/maven2, releases=true,
> snapshots=false)
>     [ERROR] -> [Help 1]
>
>
> Thanks for any help!
>
> Best regards,
>
> Richard
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message