maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anders Hammar <and...@hammar.net>
Subject Re: arcehtype:create-from-project not honoring -s parameter in integration-test phase
Date Sat, 13 Jul 2013 06:51:04 GMT
Sorry, no.

/Anders (mobile)
Den 13 jul 2013 01:40 skrev "Darryl Mocek" <darryl.mocek@oracle.com>:

> Hi Anders,
>
>    I created http://jira.codehaus.org/**browse/ARCHETYPE-445<http://jira.codehaus.org/browse/ARCHETYPE-445>.
>  Any suggestions for a workaround?
>
> Thanks,
> Darryl
>
> On 07/12/2013 03:54 PM, Anders Hammar wrote:
>
>> I think you should file a new ticket as the existing one is for a
>> different
>> goal.
>> /Anders (mobile)
>> Den 12 jul 2013 23:51 skrev "Darryl Mocek" <darryl.mocek@oracle.com>:
>>
>>  I am running maven within a firewall and have a mirror of the Maven
>>> repository within the coporate firewall.  When specifying a proxy and
>>> using
>>> Maven Central, or just about any mirror, I get build errors, so I need to
>>> use our internal mirror.  The build is faster this way as well.  I have a
>>> settings.xml file which contains information on our mirror and without a
>>> proxy set so we only use the internal mirror.  When running the
>>> maven-archtype-plugin by using:
>>>
>>> mvn -X -s /path/to/my/settings.xml archetype:create-from-project
>>>
>>> I see this DEBUG statement
>>>
>>> [DEBUG] Added basic integration test
>>> [INFO] Scanning for projects...
>>>
>>> then maven attempts to download these two files:
>>>
>>> org/apache/maven/archetype/****archetype-packaging/2.2/**
>>> archetype-packaging-2.2.pom
>>> org/apache/maven/archetype/****archetype-packaging/2.2/**
>>> archetype-packaging-2.2.jar
>>>
>>> However, the download is from Maven Central outside the firewall, which
>>> causes the build to fail.  It appears that the settings parameter isn't
>>> being propagated to the integration-test phase.  How can I get the
>>> integration-test phase to use the settings.xml file I've specified?
>>>
>>> BTW, I found this bug reported: http://jira.codehaus.org/**
>>> browse/ARCHETYPE-411 <http://jira.codehaus.org/**browse/ARCHETYPE-411<http://jira.codehaus.org/browse/ARCHETYPE-411>
>>> >,
>>> which looks like the same basic issue.
>>>
>>> Thanks
>>>
>>> ------------------------------****----------------------------**
>>> --**---------
>>> To unsubscribe, e-mail: users-unsubscribe@maven.**apac**he.org<http://apache.org>
>>> <users-unsubscribe@**maven.apache.org<users-unsubscribe@maven.apache.org>
>>> >
>>> For additional commands, e-mail: users-help@maven.apache.org
>>>
>>>
>>>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: users-unsubscribe@maven.**apache.org<users-unsubscribe@maven.apache.org>
> For additional commands, e-mail: users-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message