maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alan Buck <Alan.B...@pharmacyonesource.com>
Subject RE: Not authorized issue when transfering metadata...
Date Mon, 08 Jul 2013 16:28:50 GMT
This is running on the Team City machine (as always it builds fine on my local machine) and
our team has been building the 1.9-SNAPSHOT successfully for months now. This is the first
build since the 4-day July 4th weekend though.

I haven't changed anything on the Team City machine but everyone in the company has access
to and can change anything on the TC machine. There are only a few of us that are brave enough
to mess with this configuration on the TC machine.

The C:\.m2 folder is empty on the TC machine. However, this is the <server> section
of the settings.xml file found in the mps directory at mps/maven/.m2. The configurations shown
here have not changed since 7/25/2012 and we build multiple times a day at each commit.

<servers>
        <server>
            <id>internal</id>
            <username>admin</username>
            <password>5archiva</password>
        </server>
        <server>
            <id>snaps</id>
            <username>admin</username>
            <password>5archiva</password>
        </server>
        <server>
            <id>plugtree-snapshot-repo</id>
            <username>p1sdev</username>
            <password>There is a password here but I removed it</password>
        </server>
</servers>

-----Original Message-----
From: Stephen Connolly [mailto:stephen.alan.connolly@gmail.com] 
Sent: Monday, July 08, 2013 9:09 AM
To: Maven Users List
Subject: Re: Not authorized issue when transfering metadata...

On 8 July 2013 16:37, Alan Buck <Alan.Buck@pharmacyonesource.com> wrote:

> I'm beginning to get the hang of Maven but I just ran into an issue 
> that I'm not sure how to rectify it.
>
> com.p1s:mps] Failed to execute goal
> org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy 
> (default-deploy) on project mps: Failed to retrieve remote metadata 
> com.p1s:mps:1.9-SNAPSHOT/
>

Could be auth issue on retrieval, or could be that this is the first 1.9-SNAPSHOT to be deployed


> maven-metadata.xml: Could not transfer metadata 
> com.p1s:mps:1.9-SNAPSHOT/maven-metadata.xml from/to snaps (dav:
> http://madarchiva:8080/archiva/repository/snapshots): Not authorized
>

Certainly an auth issue trying to deploy

>
> I'm building a project, mps, that is throwing the above error. I'm not 
> sure how to interpret this but I think it is saying that in the 
> maven-deploy-plugin (version 2.7) there is an authorization problem.
>

Have you got the correct user auth details in ~/.m2/setttings.xml in the <servers> section
under a <server> with the <id> matching the <id> in your <distributionManagement><snapshotRepository>
in your pom?


>
> Is this authorization to get something from madarchiva or is it trying 
> to get something from com.p1s:mps:1.9-SNAPSHOT?
>
> Any help in understanding this error message would be appreciated.
>
> Alan
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message