maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Sand" <>
Subject bad request return code from Sonatype doing release:perform
Date Fri, 19 Jul 2013 12:25:26 GMT
Hi all - trying to get my first plugin released into Maven Central. The
snapshot is there, and release:prepare executed fine.

When I run release:perform, I'm getting a 400-Bad Request error when maven
tries to download something from the Sonatype parent when I do the release.
Has anyone seen this error? Since all of the reports/site plugin ran
successfully on the snapshot, does it matter if I just disable them for the
release goal? I've got a ticket open with Sonatype but thought someone on
the list may have encountered this before.

  [INFO] <<< maven-plugin-plugin:3.2:report (report:report) @
idfc-proguard-maven-plugin <<<
    [INFO] Parent project loaded from repository:
    [INFO] Total time: 31.175s
    [INFO] Finished at: Thu Jul 18 10:16:19 EDT 2013
    [INFO] Final Memory: 31M/75M
    [ERROR] Failed to execute goal
org.apache.maven.plugins:maven-site-plugin:3.3:site (default-site) on
project idfc-proguard-maven-plugin: SiteToolException: The site descriptor
cannot be resolved from the repository: ArtifactResolutionException: Unable
to locate site descriptor: Could not transfer artifact
org.sonatype.oss:oss-parent:xml:site_en:7 from/to
( Failed to
transfer file:
s/oss-parent/7/oss-parent-7-site_en.xml. Return code is: 400 ,
ReasonPhrase:Bad Request.
    [ERROR] org.sonatype.oss:oss-parent:xml:7
    [ERROR] from the specified remote repositories:
releases=true, snapshots=true),
    [ERROR] sonatype-nexus-snapshots
(, releases=false,
    [ERROR] central (, releases=true,
    [ERROR] -> [Help 1]

Thanks for any help!

Best regards,


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message