maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud Héritier <aherit...@gmail.com>
Subject Re: maven-release-plugin with github project
Date Sat, 27 Jul 2013 16:52:33 GMT
Someone show me a similar issue with the release plugin in a project
using git where the parent/reactor is at the same level than modules
(moreover each modules where git submodules AFAIR )

The usage of relative path with in the reactor breaks the release.
There is an issue in Jira with a patch but AFAIR there was only the
code fix (no new test ..)

---------
Arnaud

Le 27 juil. 2013 à 18:14, "Alejandro.Endo@miranda.com"
<Alejandro.Endo@miranda.com> a écrit :

>
>
> I'm  trying to release a multimodule maven project cloned in github. My  project has
the parent pom as a submodule of the root aggregator. if i  run the release in dryRun mode
it works fine, however if I run it for  real this is what i get near the end
>
>
> ...
> [INFO] Checking in modified POMs...
> [INFO]  Executing: /bin/sh -c cd "/home/hilikus/dev/Eclipse workspace/JRoboCom"  &&
git add -- jrobocom-parent/pom.xml jrobocom-core/pom.xml  jrobocom-simple-gui/pom.xml jrobocom-samples/pom.xml
 jrobocom-samples/legends/pom.xml jrobocom-samples/simple/pom.xml  jrobocom-samples/simple/4Lunch/pom.xml
 jrobocom-samples/simple/black-jacks/pom.xml  jrobocom-samples/simple/bank-jumper/pom.xml
pom.xml
> [INFO] Working directory: /home/hilikus/dev/Eclipse workspace/JRoboCom
> [INFO] Executing: /bin/sh -c cd "/home/hilikus/dev/Eclipse workspace/JRoboCom" &&
git status
> [INFO] Working directory: /home/hilikus/dev/Eclipse workspace/JRoboCom
> [INFO]  Executing: /bin/sh -c cd "/home/hilikus/dev/Eclipse workspace/JRoboCom"  &&
git commit --verbose -F /tmp/maven-scm-646807004.commit  jrobocom-parent/pom.xml jrobocom-core/pom.xml
 jrobocom-simple-gui/pom.xml jrobocom-samples/pom.xml  jrobocom-samples/legends/pom.xml jrobocom-samples/simple/pom.xml
 jrobocom-samples/simple/4Lunch/pom.xml  jrobocom-samples/simple/black-jacks/pom.xml  jrobocom-samples/simple/bank-jumper/pom.xml
pom.xml
> [INFO] Working directory: /home/hilikus/dev/Eclipse workspace/JRoboCom
> [INFO] Executing: /bin/sh -c cd "/home/hilikus/dev/Eclipse workspace/JRoboCom" &&
git symbolic-ref HEAD
> [INFO] Working directory: /home/hilikus/dev/Eclipse workspace/JRoboCom
> [INFO]  Executing: /bin/sh -c cd "/home/hilikus/dev/Eclipse workspace/JRoboCom"  &&
git push  https://github.com/theHilikus/JRoboCom.git/jrobocom-aggregator  master:master
> [INFO] Working directory: /home/hilikus/dev/Eclipse workspace/JRoboCom
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO]
> [INFO] Parent POM ........................................ SKIPPED
> ...
> [INFO] Bank-jumper ....................................... SKIPPED
> [INFO] The overall aggregator ............................ FAILURE [3:30.447s]
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 3:32.658s
> [INFO] Finished at: Tue Jul 23 22:31:43 EDT 2013
> [INFO] Final Memory: 9M/44M
> [INFO] ------------------------------------------------------------------------
> [ERROR]  Failed to execute goal  org.apache.maven.plugins:maven-release-plugin:2.4.1:prepare
 (default-cli) on project jrobocom-aggregator: Unable to commit files
> [ERROR] Provider message:
> [ERROR] The git-push command failed.
> [ERROR] Command output:
> [ERROR]  fatal:  https://github.com/theHilikus/JRoboCom.git/jrobocom-aggregator/info/refs
 not found: did you run git update-server-info on the server?
> [ERROR] -> [Help 1]
>
>
> If  I run that same git push command by hand it does give me that error,  however, if
i run the push with the url just up to .git and remove the /jrobocom-aggregator it works fine
>
> Where  does the MRP take the push url from? i'm running mvn from the root  aggregator
since i want to release all submodules together but i don't  see why the push url should include
the aggregator's artifact id
>
> What am i doing wrong? this seems like the canonical release procedure
>
> This  is the aggregator POM (before running the release) in case anyone is  interested
https://github.com/theHilikus/JRoboCom/blob/master/pom.xml  and from there you can find all
the other poms
>
> Thank you,
> DISCLAIMER:
> Privileged and/or Confidential information may be contained in this
> message. If you are not the addressee of this message, you may not
> copy, use or deliver this message to anyone. In such event, you
> should destroy the message and kindly notify the sender by reply
> e-mail. It is understood that opinions or conclusions that do not
> relate to the official business of the company are neither given
> nor endorsed by the company.
> Thank You.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message