maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schaible <>
Subject Re: Multiple JDK versions
Date Tue, 25 Jun 2013 10:05:59 GMT
Hi Virg,

virg g wrote:

> Yes. We have multiple customers, some of them support 1.5 and others 1.6.
> We need to release both the builds with 1.5 and 1.6.


sorry, in this case it simply does not make sense to use different JDKs. If 
you are able to compile the same sources for JDK 1.5 and JDK 1.6, the source 
*must* be compatible to JDK 1.5.

Let's take it to the extreme. Have a look at current commons-logging-1.1.3. 
That one is JDK 1.1 compatible. With your logic, Apache commons sould have 
to release commons-logging for JDK 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7 and 
soon for 1.8. Do you find such releases somewhere? No, because it is 
absolutely not necessary.

So, compile your source with target JDK 1.5 and you're done.

- Jörg

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message