maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Tran <dant...@gmail.com>
Subject Re: Can't manage to download a site with wagon maven plugin
Date Thu, 13 Jun 2013 09:32:15 GMT
scanning http site is tricky, it needs to scan the directory page with from
predictable format.  You may want to dig a little deeper into wagon-http

-D


On Thu, Jun 13, 2013 at 1:55 AM, Jeff MAURY <jeffmaury@jeffmaury.com> wrote:

> Hello,
>
> I want to setup my pom in order to dowload a remote web site through HTTP.
> Here is my POM:
>
> <project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="
> http://www.w3.org/2001/XMLSchema-instance"
>  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
>  <modelVersion>4.0.0</modelVersion>
>
> <groupId>com.jeffmaury</groupId>
>  <artifactId>wagon-http-test</artifactId>
> <version>0.0.1-SNAPSHOT</version>
> <packaging>jar</packaging>
>
> <name>wagon-http-test</name>
> <url>http://maven.apache.org</url>
>
> <properties>
> <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
>  </properties>
>
> <build>
> <extensions>
>  <extension>
> <groupId>org.apache.maven.wagon</groupId>
> <artifactId>wagon-http</artifactId>
>  <version>2.4</version>
> </extension>
> </extensions>
>  <plugins>
> <plugin>
> <groupId>org.codehaus.mojo</groupId>
>  <artifactId>wagon-maven-plugin</artifactId>
> <version>1.0-beta-4</version>
>  <executions>
> <execution>
> <phase>generate-resources</phase>
>  <goals>
> <goal>download</goal>
> </goals>
>  </execution>
> </executions>
> <configuration>
>  <url>http://www.syspertec.com</url>
> <fromDir>/</fromDir>
>  <toDir>${project.outputDirectory}/test</toDir>
> <includes>**/*</includes>
>  </configuration>
> </plugin>
> </plugins>
>  </build>
> </project>
>
> Here is the output:
>
> [INFO] Scanning for projects...
> [INFO]
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Building wagon-http-test 0.0.1-SNAPSHOT
> [INFO]
> ------------------------------------------------------------------------
> [INFO]
> *[INFO] --- wagon-maven-plugin:1.0-beta-4:download (default) @
> wagon-http-test ---*
> *[INFO] Scanning remote file system: http://www.syspertec.com ...*
> *[INFO] Nothing to download.*
> [INFO]
> [INFO] --- maven-resources-plugin:2.5:resources (default-resources) @
> wagon-http-test ---
> [debug] execute contextualize
> [INFO] Using 'UTF-8' encoding to copy filtered resources.
> [INFO] skip non existing resourceDirectory
> d:\workspace\wagon-http-test\src\main\resources
> [INFO]
> [INFO] --- maven-compiler-plugin:2.3.2:compile (default-compile) @
> wagon-http-test ---
> [INFO] Nothing to compile - all classes are up to date
> [INFO]
> ------------------------------------------------------------------------
> [INFO] BUILD SUCCESS
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 3.162s
> [INFO] Finished at: Thu Jun 13 10:53:50 CEST 2013
> [INFO] Final Memory: 6M/73M
> [INFO]
> ------------------------------------------------------------------------
> /d/workspace/wagon-http-test
>
> Any help ?
> --
> Jeff MAURY
> PS; I'm posting to Maven user list instead of Mojo because I suspect this
> is related to wagon-http
>
>
> "Legacy code" often differs from its suggested alternative by actually
> working and scaling.
>  - Bjarne Stroustrup
>
> http://www.jeffmaury.com
> http://riadiscuss.jeffmaury.com
> http://www.twitter.com/jeffmaury
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message