maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Branson <don.bran...@gmail.com>
Subject Re: With mvn release:prepare, is it possible to instruct Maven to use a forward slash in the submodule pom locations for the commit command?
Date Fri, 28 Jun 2013 21:36:56 GMT
Mark, I did see that. It's for Maven 2.x, I'm running 3.0.5. The bug is
marked "Unresolved." Its presence in 3.0.5 seems to confirm that. I'd be
surprised if the patch is still applicable in maven 3.


On Fri, Jun 28, 2013 at 4:22 PM, Mark Eggers <its_toasted@yahoo.com> wrote:

> Top-posting, which seems to be the style for this thread:
>
> Have you looked at:
>
> http://jira.codehaus.org/**browse/MRELEASE-581<http://jira.codehaus.org/browse/MRELEASE-581>
>
> to see if the proposed patch fixes things for you?
>
> /mde/
>
>
> On 6/28/2013 2:04 PM, Don Branson wrote:
>
>> I'm open to linux/mac, yes, but is my client? Not as much...
>>
>> I've thought about using the windows environment for this. I'd have
>> to use a windows-based git instead of the cygwin one, and may or may
>> not be able to install that on our locked-down machines. I'll do it
>> if I have to, but I'm hoping to find a solution that lets me stay in
>> bash. If it comes down to it, I'll do all my work on my desktop, and
>> use a linux host for the release process.
>>
>>
>> On Fri, Jun 28, 2013 at 3:55 PM, Russell Gold <russ@gold-family.us>
>> wrote:
>>
>>  I don't suppose you're open to the solution: "use linux or mac"?
>>>
>>> I think what you're running into a general cygwin problem: other
>>> than those built it, the tools are mostly windows tools and expect
>>> path names to refer to the windows file system, but cygwin uses its
>>> own paths and they don't always match.
>>>
>>> Have you tried running directly in the windows environment without
>>> cygwin?
>>>
>>> On Jun 28, 2013, at 4:37 PM, Don Branson <don.branson@gmail.com>
>>> wrote:
>>>
>>>  I'm trying to resolve an issue which I've posted at
>>>>
>>>>  http://stackoverflow.com/**questions/17367079/with-mvn-**
>>> releaseprepare-is-it-possible-**to-instruct-maven-to-use-a-**
>>> forward-slas<http://stackoverflow.com/questions/17367079/with-mvn-releaseprepare-is-it-possible-to-instruct-maven-to-use-a-forward-slas>
>>>
>>>
>>>  .
>
>> Is this a known issue with Maven+git+Cygwin? Is there a
>>>> solution?
>>>>
>>>> -- Don Branson
>>>>
>>>
>>> ----------------- Come read my webnovel, Take a Lemon
>>> <http://www.takealemon.com>, and listen to the Misfile radio play
>>> < http://www.gold-family.us/**audio/misfile.html<http://www.gold-family.us/audio/misfile.html>
>>> >!
>>>
>>>
>>>
>>>
>>>
>>>
>>
>>
>
> ------------------------------**------------------------------**---------
> To unsubscribe, e-mail: users-unsubscribe@maven.**apache.org<users-unsubscribe@maven.apache.org>
> For additional commands, e-mail: users-help@maven.apache.org
>
>


-- 
Don Branson

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message