maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From virg g <06v...@gmail.com>
Subject Re: Multiple JDK versions
Date Tue, 25 Jun 2013 11:19:00 GMT
Yes you are absolutely right, I totally agree with you. I am asked to
implement these kind of builds.


On Tue, Jun 25, 2013 at 3:35 PM, Jörg Schaible
<Joerg.Schaible@scalaris.com>wrote:

> Hi Virg,
>
> virg g wrote:
>
> > Yes. We have multiple customers, some of them support 1.5 and others 1.6.
> > We need to release both the builds with 1.5 and 1.6.
>
> [snip]
>
> sorry, in this case it simply does not make sense to use different JDKs. If
> you are able to compile the same sources for JDK 1.5 and JDK 1.6, the
> source
> *must* be compatible to JDK 1.5.
>
> Let's take it to the extreme. Have a look at current commons-logging-1.1.3.
> That one is JDK 1.1 compatible. With your logic, Apache commons sould have
> to release commons-logging for JDK 1.1, 1.2, 1.3, 1.4, 1.5, 1.6, 1.7 and
> soon for 1.8. Do you find such releases somewhere? No, because it is
> absolutely not necessary.
>
> So, compile your source with target JDK 1.5 and you're done.
>
> - Jörg
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message