maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lee Meador <...@leemeador.com>
Subject Re: Compile errors that make no sense
Date Mon, 10 Jun 2013 16:20:08 GMT
Compile plugin has both set to 1.6. Using 'java version "1.6.0_35"'
according to "java -version" when I do "mvn package"

I gave in and added a dependency to xmlbeans 1.0 and it compiled and built
my jar. Still don't know why and that makes me nervous. Perhaps I'll have
to kill a chicken on my monitor to keep it working. (It's harder with the
thin monitors.)

Thank you for your help.

--- Lee


On Fri, Jun 7, 2013 at 9:35 PM, Wayne Fay <waynefay@gmail.com> wrote:

> > [ERROR]
> >
> \java\f1400\src\fcs\code\src\com\company\interfaces\nds\NDSBoundary.java:[66,80]
> ...
> > Notice that it complains about com.bea.xml.X on three lines. But the
> > snippet of source code on the next lines does not show a reference to
> the X
> > class. Its not an Exception either.
> >
> > In fact, a text search on all the source code finds no references to
> > com.bea.xml . I tried it twice typing and copy/pasting to check.
>
> It certainly sounds odd. What JDK are you using? What version of the
> compiler is specified as source and target? Can you post this
> NDSBoundary.java file somewhere like pastebin or create a simple/small
> project that demonstrates this issue without disclosing large portions
> of your company/private source?
>
> Wayne
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>
>


-- 
-- Lee Meador
Sent from gmail. My real email address is lee AT leemeador.com

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message