maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: Having trouble using Maven release plugin to deploy artifact to a dav repo
Date Fri, 28 Jun 2013 19:18:45 GMT
did you make sure your server settings contains YOUR authentication credentials (supplied key)

to quote the doc:
"You should, of course, make sure that you can login into the specified SSH server by hand
before attempting the deployment with Maven. Once you have verified that everything is setup
correctly you can now deploy your artifacts using Maven:"
mvn deployhttp://maven.apache.org/plugins/maven-deploy-plugin/examples/deploy-ssh-external.html

Martin ______________________________________________ 
Verzicht und Vertraulichkeitanmerkung/Note de déni et de confidentialité

Diese Nachricht ist vertraulich. Sollten Sie nicht der vorgesehene Empfaenger sein, so bitten
wir hoeflich um eine Mitteilung. Jede unbefugte Weiterleitung oder Fertigung einer Kopie ist
unzulaessig. Diese Nachricht dient lediglich dem Austausch von Informationen und entfaltet
keine rechtliche Bindungswirkung. Aufgrund der leichten Manipulierbarkeit von E-Mails koennen
wir keine Haftung fuer den Inhalt uebernehmen.
Ce message est confidentiel et peut être privilégié. Si vous n'êtes pas le destinataire
prévu, nous te demandons avec bonté que pour satisfaire informez l'expéditeur. N'importe
quelle diffusion non autorisée ou la copie de ceci est interdite. Ce message sert à l'information
seulement et n'aura pas n'importe quel effet légalement obligatoire. Étant donné que les
email peuvent facilement être sujets à la manipulation, nous ne pouvons accepter aucune
responsabilité pour le contenu fourni.

 
> Date: Fri, 28 Jun 2013 09:10:31 -0700
> From: laredotornado@gmail.com
> To: users@maven.apache.org
> Subject: Re: Having trouble using Maven release plugin to deploy artifact to a dav repo
> 
> Hi, Per your suggestion, I added a developerConnection alongside the
> <connection> and upgraded to the 1.0 connector, but still ran into the same
> error.   Note that the distrubtionManagemetn is next to scm, not inside. 
> Here is the updated pom ...
> 
> 
> <?xml version="1.0"?>
> <project xmlns="http://maven.apache.org/POM/4.0.0"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> 	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
> http://maven.apache.org/xsd/maven-4.0.0.xsd">
> 	<modelVersion>4.0.0</modelVersion>
> 	<groupId>org.mainco.subco</groupId>
> 	<artifactId>test</artifactId>
> 	<version>1.3-SNAPSHOT</version>
> 	<name>test</name>
> 	<url>http://maven.apache.org</url>
> 	<properties>
> 		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
> 	</properties>
> 	<dependencies>
> 		<dependency>
> 			<groupId>junit</groupId>
> 			<artifactId>junit</artifactId>
> 			<version>3.8.1</version>
> 			<scope>test</scope>
> 		</dependency>
> 	</dependencies>
> 
> 	<build>
> 		<extensions>
> 			<extension>
> 				<groupId>org.apache.maven.wagon</groupId>
> 				<artifactId>wagon-webdav-jackrabbit</artifactId>
> 				<version>1.0</version>
> 			</extension>
> 		</extensions>
> 	</build>
> 
> 	<scm>
> 	
> <connection>scm:svn:https://subversion.bidomain/svn/subco-digital.coderepo/repo</connection>
> 	
> <developerConnection>scm:svn:https://subversion.bidomain/svn/subco-digital.coderepo/repo</developerConnection>
> 	</scm>
> 	<distributionManagement>
> 		<repository>
> 			<id>cloudbees-private-repository</id>
> 			<url>dav:https://repository-vendor.forge.externaldomain/release/</url>
> 		</repository>
> 	</distributionManagement>
> </project>
> 
> Error was "Failed to execute goal
> org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on
> project test: Failed to deploy artifacts/metadata: No connector available to
> access repository cloudbees-private-repository
> (dav:https://repository-vendor.forge.externaldomain/release/) of type
> default using the available factories WagonRepositoryConnectorFactory ->
> [Help 1]".
> 
> 
> 
> --
> View this message in context: http://maven.40175.n5.nabble.com/Having-trouble-using-Maven-release-plugin-to-deploy-artifact-to-a-dav-repo-tp5761093p5761109.html
> Sent from the Maven - Users mailing list archive at Nabble.com.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message