maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From laredotornado-3 <laredotorn...@gmail.com>
Subject Re: Having trouble using Maven release plugin to deploy artifact to a dav repo
Date Fri, 28 Jun 2013 16:10:31 GMT
Hi, Per your suggestion, I added a developerConnection alongside the
<connection> and upgraded to the 1.0 connector, but still ran into the same
error.   Note that the distrubtionManagemetn is next to scm, not inside. 
Here is the updated pom ...


<?xml version="1.0"?>
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
http://maven.apache.org/xsd/maven-4.0.0.xsd">
	<modelVersion>4.0.0</modelVersion>
	<groupId>org.mainco.subco</groupId>
	<artifactId>test</artifactId>
	<version>1.3-SNAPSHOT</version>
	<name>test</name>
	<url>http://maven.apache.org</url>
	<properties>
		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
	</properties>
	<dependencies>
		<dependency>
			<groupId>junit</groupId>
			<artifactId>junit</artifactId>
			<version>3.8.1</version>
			<scope>test</scope>
		</dependency>
	</dependencies>

	<build>
		<extensions>
			<extension>
				<groupId>org.apache.maven.wagon</groupId>
				<artifactId>wagon-webdav-jackrabbit</artifactId>
				<version>1.0</version>
			</extension>
		</extensions>
	</build>

	<scm>
	
<connection>scm:svn:https://subversion.bidomain/svn/subco-digital.coderepo/repo</connection>
	
<developerConnection>scm:svn:https://subversion.bidomain/svn/subco-digital.coderepo/repo</developerConnection>
	</scm>
	<distributionManagement>
		<repository>
			<id>cloudbees-private-repository</id>
			<url>dav:https://repository-vendor.forge.externaldomain/release/</url>
		</repository>
	</distributionManagement>
</project>

Error was "Failed to execute goal
org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on
project test: Failed to deploy artifacts/metadata: No connector available to
access repository cloudbees-private-repository
(dav:https://repository-vendor.forge.externaldomain/release/) of type
default using the available factories WagonRepositoryConnectorFactory ->
[Help 1]".



--
View this message in context: http://maven.40175.n5.nabble.com/Having-trouble-using-Maven-release-plugin-to-deploy-artifact-to-a-dav-repo-tp5761093p5761109.html
Sent from the Maven - Users mailing list archive at Nabble.com.

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message